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Purpose  
The Budget module helps you manage and track company expenses. 

In SAP Business One a budget is based on the data entered, which specifies the maximum amount 
that can be allocated to a particular G/L account. You can block the creation of transactions for G/L 
accounts that exceed their budget limit. 

In the course of routine work, the application checks the debit side of G/L accounts for which a budget 
has been defined. If the budget is exceeded, the application either issues a warning or blocks the 
action, depending on the chosen setting. 

 Note 
 The budget functionality works with calendar months only. 

 If your company manages a perpetual inventory system, you can use Purchase 
Accounts Posting System.  This option includes the recording of expense 
accounts in journal entries created by purchasing documents that affect the 
inventory valuation. You can use the budget functionality to control these 
purchase accounts, thus monitoring your expenses in real time.  

This functionality can be used in localizations where purchase accounting is used, 
selecting this option enables purchase accounting. Once journal entries have 
been made, this setting cannot be modified. 

To activate the Purchase Accounts Posting System, from SAP Business One 
Main Menu, choose Administration → System Initialization → Company Details → 
Basic Initialization tab and select the Use Purchase Accounts Posting System 
checkbox. 
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Defining Budget Settings 
You need to make specific settings before you can use the budget functionality. 

1. From the SAP Business One Main Menu, choose Administration → System Initialization → 
General Settings, and on the Budget tab select the Budget Initialization checkbox. 

 

 

2. Under the title For a Document that Deviates from the Budget, choose one of the following 
options: 

 Block Deviation from Budget - blocks the creation of transactions that cause the budget 
to be exceeded. 

 Warning - in the event that the budget is exceeded, issues an alert, offering you the 
option of confirming or canceling the transaction. 

 Without Warning – lets you add transactions without any restrictions. When you choose 
this option, the rest of the fields are not displayed. 

3. Specify the following data: 

Field/Button Activity/Description Comments  

For Annual/Monthly 
Budget 

Lets you manage your budget on 
an annual or monthly basis. 

For the annual budget, this 
setting is updated per user. 
For the monthly budget, it is 
updated for all users in the 
company, but only after the 
next logon. 

Purchase Orders When you issue a purchase order, 
the application performs a check 
against the budget, including all 
open purchase orders and the 
current one. 
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Field/Button Activity/Description Comments  

Goods Receipt POs When you issue a goods receipt 
PO, the application performs a 
check against the budget, including 
all open goods receipt POs and the 
current one. 

 

Accounting When you issue an A/P invoice or 
any other accounting transaction 
that involves a G/L account 
relevant to the budget, the 
application performs a check. 

 

 

4. To save changes, choose the Update Button. 

5. When SAP Business One displays the Mark all P&L accounts as budget accounts? dialog box, 
choose Yes. 

Result 

The Relevant to Budget checkbox is selected in all your profit-and-loss G/L accounts.  

 Note 
 You can find this checkbox in Financials → Chart of Accounts → Account Details 

pushbutton. 

 You can manually select non profit-and-loss G/L accounts to be relevant to the 
budget by selecting the Relevant to Budget checkbox for each G/L account. 

In the course of routine work, when you create a transaction against a relevant-to-budget expense G/L 
account, the application executes a check for deviation from the budget, and if the budget is 
exceeded, it issues a system message. 

If the Purchase Order, Goods Receipt POs, and Accounting checkboxes are selected, the application 
performs a check for deviation from the budget during the generation of purchase orders, goods 
receipt POs, and A/P invoices. 

If the budget is exceeded, the following dialog box is displayed: 

 
 

If you defined to block transactions that exceed the budget, the application does not add such 
transactions and issues an alert to that effect. 

© SAP AG 2009 5



How to Manage Budgets  

Defining Budget Distribution Methods 
You can automatically divide the budget among the months of the year. 

 Note 
Budget distribution methods are not relevant for working with an annual. 

During the setup of a new company, SAP Business One automatically defines the following 3 common 
budget distribution methods: 

• Equal –distributes the budget amount equally among the months of the year. 

• Ascending Order –distributes the budget amount in an ascending order and is used when you 
increase your budget expenses over the months of the year.  

For example, in January you use only a small proportion of your budget amount, in February 
you increase your expenses, and so on. 

• Descending Order - distributes the budget amount in a descending order and is used when you 
decrease your budget expenses over the months of the year. 

For example, in January you use the largest proportion of your budget amount, in February you 
use a little less, and so on. 

These methods cannot be revised. However, you can choose to add additional methods as described 
in the following procedure. 

Procedure 

1. From the SAP Business One Main Menu, choose Financials → Budget Setup → Budget 
Distribution Methods. 
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2. To switch to Add mode, use one of the following methods: 

 From the menu bar, choose Data → Add 

 Click (Add) in the toolbar 

 Press Ctrl+A 

3. In the Budget Distribution Methods – Setup window, specify the following data: 

Field/Button Activity/Description Comments  

Method Internal number automatically 
assigned to the distribution 
method. 

 

Method Name Specify a name for the distribution 
method. 

 

Total Specify the total value to be 
distributed among the months. 

 

Month A numerical representation of the 
month of the year. 

 

Factor Define the proportion of the total to 
be assigned to each month.  

The factor total has to match 
the total distribution. 

Set as Default Lets you define a certain 
distribution method as the default 
method.  

This setting automatically 
selects the chosen method 
when you define the budget. 

 

4. To add your chosen method, click the Add button. 

 Note 
You can change the distribution of the budget amounts manually in the Budget Item 
Details window. For more information, see Changing the Distribution of Budget 
Amounts. 
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Using Budget Scenarios 
Budget scenarios are used mainly for displaying budget reports. Using a scenario, you create a 
prognosis of a particular situation for the company's budget and obtain important information about 
what the budgetary balance would be according to the selected scenario. 

 Example 
This figure illustrates an optimistic scenario versus a pessimistic scenario. Each budget 
scenario is assigned to a particular fiscal year. 

 

 

When you set up a new company, the application provides a default scenario called Main Budget. This 
scenario cannot be altered. 

Defining a New Budget Scenario 
1. From the SAP Business One Main Menu, choose Financials → Budget Setup → Budget 

Scenarios. 

The scenarios assigned to the selected fiscal year are displayed. 
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2. In the Fiscal Year field choose a different fiscal year to display its assigned scenarios. 

The options in Fiscal Year are based on the posting periods you set in the Posting Periods 
window (Administration → System Initialization → Posting Periods). 

 Note 
You can set a Fiscal Year start for the first day of the month only. 

3. To add a new budget scenario row, use one of the following methods: 

 From the menu bar, choose Data → Add Row 

 Right-click in the window and choose Add Row 

 Press Ctrl+I 

4. In the Budget Scenarios – Setup window, specify the following data: 

Field/Button Activity/Description Comments  

Budget Name Specify a name for the budget 
scenario.  

This name is unique to that 
fiscal year. 

Based On Choose the budget scenario on 
which to base this budget scenario. 

An independent budget 
scenario should be based on 
itself. 

Initial Ratio (%) Set the percentage of the defined 
budget in relation to its base 
budget. 

 

Rounding Method Select one of the following 
rounding methods for budget 
amounts in the scenario: 

• No Rounding 

• Round to Full Decimal 
Amount 

• Round to Full Amount 

• Round to Full Tens Amount 

Changing the rounding method is 
relevant only when you base your 
scenario on a different one. Budget 
amounts for independent budget 
scenarios are not rounded. 

The budget amounts are 
rounded only when the 
scenario is created. If you 
later define or change a 
budget amount in the base 
scenario, the budget amount 
calculated for this scenario is 
not rounded. 

For examples, see Appendix 
- Examples of Rounding 
Methods. 

 

Copy Scenario Opens the Copy Budget Scenarios 
window. 

Import Scenario Opens the Import Budget 
Scenarios window. 

For information, see sections 
Importing Budget Scenarios 
and Copying Budget 
Scenarios. 
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5. To save your settings, choose the Update button. 

 Note 
 You can update a particular scenario by going to the Budget Scenario Definition 

window and entering amounts manually, irrespective of the ratio that has been 
defined. For information, see Defining a Budget. 

 In the course of routine work, deviation from the budget is checked against the 
main budget only. The other scenarios are only for reports. 

Importing Budget Scenarios  
The Import Budget Scenario function lets you import budget data from a company to the company with 
which you are currently working, and duplicate a budget scenario in the same company, for the same 
fiscal year or for the next fiscal year. 

 Note 
Make sure during the operation that the G/L account codes in the source company match 
those in the target company. 

1. From the SAP Business One Main Menu, choose Financials → Budget Setup → Budget 
Scenarios. 

2. To open the Import Budget Scenarios window, choose the Import Scenario button. 

 
 

The window contains the following data: 

Field/Button Activity/Description Comments  

Original Data 

Choose Company Select the source company from 
which to import the source 
scenario. 

 

Database Name  Displays the database name of the 
selected source company. 
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Field/Button Activity/Description Comments  

Company Name Displays the company name of the 
selected source company. 

 

Original Scenario Select the required scenario to 
import. 

 

Destination Data 

Database Name  Displays the database name of the 
company you are currently working 
in, and into which you are importing 
the budget data (cannot be 
changed).   

 

Company Name Displays the company name of the 
company you are currently working 
in, and into which you are importing 
the budget data (cannot be 
changed). 

 

Destination Scenario Select the target scenario into 
which you want to import the 
budget scenario data. 

 

 

3. Choose the Choose Company button to open a corresponding window. Select the required 
company database and choose the OK button. 

4. Specify the Original Scenario and the Destination Scenario. 

5. On the right, select the required G/L accounts. All the G/L accounts defined as Relevant to 
Budget are displayed in this list and all are selected by default. 

6. To complete the import procedure, choose the Execute button. 

 Note 
To duplicate a budget for the next fiscal year, make sure that the source and target 
scenarios have the same name. 
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Copying Budget Scenarios  
The Copy Budget Scenario function lets you copy budget data from a budget scenario into a target 
budget scenario in the same company for the same fiscal year or for the next fiscal year.  

1. From the SAP Business One Main Menu, choose Financials → Budget Setup → Budget 
Scenarios. 

2. To open the Copy Budget Scenarios window, choose the Copy Scenario button. 

 
 

The window contains the following data: 

Field/Button Activity/Description Comments  

Original Data 

Database Name, 
Company Name 

Display your current database 
name and company name. 

 

Original Scenario Select the scenario you want to 
copy. 

 

Destination Data 

Database Name, 
Company Name 

Display your current database 
name and company name. 

 

Destination Scenario Select the target scenario to which 
you want to copy the data from the 
original budget scenario. 

 

 

3. Select the original scenario and the destination scenario of your company. 

4. On the right, select the required G/L accounts. All the G/L accounts defined as Relevant to 
Budget are displayed in this list and all are selected by default. 

5. To complete the copy procedure, choose the Execute button. 

 Note 
To duplicate a budget for the next fiscal year, make sure the source and target scenarios 
have the same name. 
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Defining a Budget 
Prerequisites 

• The Budget Initialization option on the Budget tab under Administration → System Initialization 
→ General Settings is selected. 

• You have defined the following: 

 Required distribution methods. For information, see Defining Budget Distribution 
Methods. 

 Required budget scenario. For information, see Defining a New Budget Scenario. 

Procedure 
1. From the SAP Business One Main Menu, choose Financials → Budget Setup → Budget. 

2. In the Budget Scenario Definition window, choose the required G/L accounts. 

The table displays G/L accounts defined as Relevant to Budget in the chart of accounts. 

 
 

3. In the Scenario field, choose the scenario for which you want to define a budget. For information 
about scenarios, see section Using Budget Scenarios. 
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4. Choose the OK button to open the Budget Scenarios - Setup (Scenario - XXX) window. 

This window displays G/L accounts defined as Relevant to Budget in the chart of accounts, and 
for which an amount was entered in the budget. 

 

Header 

Field/Button Activity/Description Comments  

Fiscal Year The fiscal year linked to the 
selected budget scenario. 

 

Display Accounts with no 
Budget 

Lets you display G/L accounts for 
which no budget amount has been 
entered. 

 

Row Details 

Field/Button Activity/Description Comments  

Acct No. The G/L account code as defined 
in the chart of accounts. 

 

Acct Name The G/L account name.  

Parent Acct You can determine the budget 
amount of a specific G/L account 
according to a percentage 
calculated from an existing budget 
amount of another G/L account. 
Use the TAB key to display a list of 
G/L accounts with budget amounts, 
select the required G/L account, 
and specify a value in the % field to 
the right.  

The option of linking budget 
amounts to parent accounts 
is used for calculations only. 
For this reason, the budget 
amount entered in the Parent 
Acc. field and divided among 
its child G/L accounts, is not 
actually deducted from the 
budget of the parent account. 
However, the budget 
amounts are managed 
separately for each G/L 
account. 
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Field/Button Activity/Description Comments  

% If you have selected a parent 
account for a certain G/L account, 
specify the proportionate budget 
percentage you want to allocate to 
the child G/L account.  

If the parent account's 
budget is $1000 and you 
define 10%, the child 
account's budget is $100. 

Method Select a default monthly budget 
distribution method from those 
defined in your company  

You can define a different 
method for each G/L 
account. 

Local Debit / Credit Specify an amount in local 
currency for each G/L account.  

SAP Business One checks 
the budget for deviations 
against the debit side. Thus, 
alerts are only triggered for 
accounts with a budgeted 
amount in the Debit column. 

You can use the Credit field 
for sales accounts to set 
revenue targets which you 
can track with the budget 
report. 

System Debit, Credit Let you manually change the 
system currency budget amounts, 
which were calculated according to 
the amounts in local currency 
multiplied by the relevant exchange 
rate.  

By default, these fields are 
hidden. 

Actual Displays the G/L account's balance 
to date based on its local currency 
journal entries in SAP Business 
One.  

 

Actual (SC) Displays the G/L account's balance 
to date based on its system 
currency journal entries in SAP 
Business One. 

By default, this field is 
hidden. 

Actual – Future - Local, 
Actual – Future - System 

Displays the future balance of the 
G/L account. The future balance 
displays the amounts of open 
purchase orders and goods receipt 
POs. 

By default, these fields are 
hidden. 

 

 Note 

• You display or hide columns in this window by clicking  (Form Settings) and 
selecting the relevant fields. 

• When you create a new budget that includes accounts without previous budget 
definitions, the window does not display any accounts. In such a case, select the 
Display Accounts with no Budget checkbox. 
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5. For each account, you can change the budget amount, percentage, and distribution method. 
You can also change the distribution of the budget amounts manually using the Budget Item 
Details window. For more information, see Changing the Distribution of Budget 
Amounts. 

6. To save your changes, choose the Update button. 

enabling you to perform an analysis by comparing the 
defined budget with the actual business activity. 

Menu, choose Financials → Budget Setup → Budget. 

uble-click the required row number 

The Budget Item Details window is displayed for the selected G/L account. 

Result 

The budget is defined for the selected accounts, 

Changing the Distribution of Budget Amounts 
Use the Budget Item Details window to manually change the distribution of the budget amounts. 

1. From the SAP Business One Main 

2. Choose the required G/L account. 

3. To access a detailed display of the G/L account's budget, do
in the table, or right-click the row and choose Row Details. 
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 The budget amount is distributed among the months according to the selected method.  

 You can manually change the amount for each month. 

 The Header area displays the following data: 

Field/Button Activity/Description Comments  

Account Number The code of the selected G/L 
account. 

 

Account Name The name of the selected G/L 
account. 

 

Total (Local) The total budget amount in local 
currency defined for the selected 
G/L account. 

 

Total (System) The total budget amount in system 
currency defined for the selected 
G/L account. 

 

 

4. Change the following data, as needed: 

Field/Button Activity/ Description Comments  

Month The month of the year. You cannot edit this field 

Local The budget amount in local 
currency that was distributed to 
each month. 

 

System The budget amount in system 
currency that was distributed to 
each month. 

 

% The proportion out of the overall 
budget amount that was distributed 
to each month. 

You cannot edit this field 

For Reconciliation If the total of the % column is not 
100, this row displays the amount 
remaining to be distributed. 

 

Remarks Specify special remarks for each 
month, if required.  

Note that the remarks are 
saved per month, so make 
sure to click the name of the 
relevant month before 
entering your remarks. 

Update Differences If you change the monthly budget 
amounts and, as a result, the total 
budget value is not fully allocated, 
choose this button to specify the 
remaining value in the budget 
amount of the last month. 
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5. To save your changes, choose the Update button. 

 Note 
If you change the budget amounts manually, the Method column in the Budget Scenarios 
– Setup window changes to Man. (manual) and is marked in red in the corresponding 
G/L account row. 

Defining Budgets after the Commencement of Activity 
When you define a budget amount for a G/L account that already has a bookkeeping balance, SAP 
Business One displays the following dialog box: 

 

 

Choose one of the following: 

Field/Button Activity/ Description Comments  

Yes Copies the current G/L account's 
bookkeeping balance to the Actual 
column. This means that SAP 
Business One considers the 
current bookkeeping balance as its 
starts to calculate the used budget 
amounts. 

 

 Example 
If you specify a budget 
amount for a G/L account 
with a current bookkeeping 
balance of USD 1000 and 
you choose Yes, SAP 
Business One copies the 
USD 1000 bookkeeping 
balance to the Actual 
column, and starts counting 
the used budget amount 
from this value. 

No Ignores the G/L account's current 
bookkeeping balance and starts 
calculating the used budget as of 
this moment (zero budget amount 
used). 

 

All Confirms the action for all the 
selected G/L accounts. 

 

Not for All Rejects the action for all the 
selected G/L accounts. 
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Printing Budgets 
SAP Business One lets you print windows, documents, and reports. You can set default print layouts 
for budgets.  

1. To print budgets, from the SAP Business One Main Menu, choose Financials → Budget Setup 
→ Budget. 

2. In the Budget Scenario Definition window, select the relevant budget and choose the OK button. 

3. From the Tools menu, choose Print Layout Designer, or click  in the toolbar. 

4. Choose the preferred printing layout. 

5. From the File menu, choose Print. 

 Note 
You can edit the default layouts or create new ones by using Print Layout Designer 

(PLD). From the Tools menu, choose Print Layout Designer, or click  in the toolbar. 

For more information about PLD, see the How to Customize Printing Layouts with the 
Print Layout Designer document, which you can download from the documentation area 
of the SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation. 
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Working with Budget Reports 

Creating Budget Report 
This report analyzes the business activities that occur during a defined period, with reference to a 
selected budget scenario. Use this window to specify selection criteria for the Budget report. 

1. From the SAP Business One Main Menu, choose Financials → Financial Reports → Budget 
Reports → Budget Report. 

The Budget Report – Selection Criteria window opens: 

 
 

2. If you are working with a multiannual company, choose the desired fiscal year. 

3. Specify the following data: 

Field/Button Activity/ Description Comments  

Scenario Select the required budget 
scenario and the required range of 
G/L accounts. 

Budget scenarios are 
displayed according to the 
selected fiscal year. 

Profit Center, Project Specify a profit center and/or a 
project to display relevant G/L 
accounts only. 

 

Annual Report, Quarterly 
Report or Monthly Report 

Specify the time frame for the 
report. 

 

Local currency or Display 
in SC (system currency) 

Specify whether to display the 
report in local or system currency. 

 

Display POs and GRPOs The amount in the Future column 
of the budget report includes open 
purchase orders and open goods 
receipt POs.  
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Field/Button Activity/ Description Comments  

Date Select a fiscal year.  

Use the months bar to select the 
required date range. Click the first 
required month, hold down the 
SHIFT key, and click the last 
required month.  

You can select the entire year by 
clicking Date.   

 

 

4. To generate the Budget report, choose the Execute button. 

 

The Budget report displays the following data: 

Header 

Field/Button Activity/ Description Comments  

Date From, To The fiscal year of the budget 
scenario. 

 

Display Subtotals Displays subtotals next to title G/L 
accounts.  

If you deselect this 
checkbox, budget balances 
are displayed only next to 
active G/L accounts. 

Row Details 

Field/Button Activity/ Description Comments  

Account Name Displays the account/title code and 
name. 

 

Budget The amount entered in the budget 
definition. 
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Field/Button Activity/ Description Comments  

Actual The G/L account balance for the 
selected period.  

 

Future The amount from open purchase 
orders and goods receipt POs 
linked to the G/L account. 

This column is displayed 
when the Display POs and 
GRPOs checkbox is 
selected. 

Total Displays the overall total of both 
the actual budget amount used 
plus the future amount to be used.  

Total = Actual + Future 

Difference The difference between the budget 
amount and the Total column. 

Difference = Budget amounts 
– (Actual + Future) 

Difference in % Calculation of the difference in 
percentage terms. 

 

 

5. To access different levels of detail in the report, click  and choose the desired level at 
the bottom right field. 

 Example 
Select 1 to display only the drawers, or select the highest level number to display all your 
G/L accounts, down to the active G/L accounts. 

6. To add a graphic display to the Budget report, click . 

 
 

7. In the Chart Style field, select a graph display. The graph options are as follows:  

 Line Graph 

 Draw Line Graph 

 Bar Graph 

 Spline Graph 

To print the graph with the Budget report, select the Print Graph checkbox. 
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Creating Balance Sheet, Trial Balance, and Profit and Loss 
Statement Budget Reports 
You can generate these reports according to a specific scenario. 

To open the relevant report, from the SAP Business One Main Menu, choose Financials → Financial 
Reports → Budget Reports → Balance Sheet/Trial Balance/Profit and Loss Statement Budget 
Reports. 

Printing Budget Reports 
SAP Business One lets you print windows, documents, and reports. You can set default print layouts 
for budget reports.  

1. To print budget reports, from the SAP Business One Main Menu, choose Financials → Financial 
Reports → Budget Reports → Budget Report. 

2. In the Budget Report – Selection Criteria window, specify the selection criteria and choose the 
Execute button. 

3. In the Budget Report window, from the Tools menu, choose Print Layout Designer, or click  
in the toolbar. 

4. Choose the preferred printing layout. 

5. From the File menu, choose Print. 

 Note 
You can edit the default layouts or create new ones by using Print Layout Designer 

(PLD). From the Tools menu, choose Print Layout Designer, or click  in the toolbar. 

For more information about PLD, see the How to Customize Printing Layouts with the 
Print Layout Designer document, which you can download from the documentation area 
of the SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation. 
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Appendix - Examples of Rounding Methods 
When budget scenarios are based on other scenarios, the budget amounts are rounded according to 
the scenario’s defined rounding method.  

For example, with a budget amount of 13.78 (calculated from a base scenario), the following table 
shows the final amount for each rounding method: 

Rounding Method Rounded Number Comments 

No Rounding 13.78  

Round to Full Decimal Amount 13.80 Round to the nearest tenth. 

0.05 or above is rounded to the next 
tenth.  

Below 0.05 is rounded to the previous 
tenth. 

Round to Full Amount 14 Round to the nearest whole number.  

0.5 or above is rounded to the next whole 
number. 

Below 0.5 is rounded to the previous 
whole number. 

Round to Full Tens Amount 10 Round to the nearest 10. 

5 or above is rounded to the next 10. 

Below 5 is rounded to the previous 10. 
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Authorizations 
For information about the authorizations required to manage budgets, see the online help for SAP 
Business One and the document How to Define Authorizations in the documentation area of SAP 
Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation. 
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Database Tables Reference 
For information about the tables used in a perpetual inventory system, see the .chm file: Database 
Tables Reference. You can download it from SAP Community Network. 

To download the Database Tables Reference .chm file: 
... 

1. Go to https://www.sdn.sap.com/irj/sdn/businessone. 

2. Under BUSINESS ONE KNOWLEDGE CENTER, click the link of the SAP Business One 
release version you want. 

3. Click the SDK Help Center link. 

4. In the File Download window, do one of the following: 

 To open the .zip file, choose the Open button; then extract the REFDB.chm file to your 
computer. 

 To save the .zip file to your computer, choose the Save button. You can open the .zip file 
and extract the REFDB.chm file later. 
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Copyrights, Trademarks, and Disclaimers 
© Copyright 2009 SAP AG. All rights reserved. 

 

The current version of the copyrights, trademarks, and disclaimers at 
http://service.sap.com/smb/sbocustomer/documentation is valid for this document. 
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