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Typographic Conventions

Type Style

Description

Example

Words or characters quoted from the screen. These include field names, screen titles,
pushbuttons labels, menu names, menu paths, and menu options.
Textual cross-references to other documents.
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Example

Emphasized words or expressions.

EXAMPLE

Technical names of system objects. These include report names, program names,
transaction codes, table names, and key concepts of a programming language when they
are surrounded by body text, for example, SELECT and INCLUDE.

Example

Output on the screen. This includes file and directory names and their paths, messages,
names of variables and parameters, source text, and names of installation, upgrade and
database tools.

Example

Exact user entry. These are words or characters that you enter in the system exactly as
they appear in the documentation.

<Example>

Variable user entry. Angle brackets indicate that you replace these words and characters
with appropriate entries to make entries in the system.

EXAMPLE

Keys on the keyboard, for example, F 2 or E N T E R .
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Document History

Version

Date

Change

2.0

2015-11-12

Guide updated for SAP Business One 9.2, version for SAP HANA. Changes are
as follows:
·

The referenced guide SAP HANA Predictive Analysis Library (PAL)
Reference was updated.

·

Pervasive analytics provide the following new predefined KPIs and
pervasive dashboard:
o Weighted Amount of All Open Opportunities (LC) (KPI)
o Average Fulfillment Days of Sales Order (KPI)
o Average Delivery Variance Days (KPI)
o Average Fulfillment Days of Purchase Order (KPI)
o Average Receipt Variance Days (KPI)
o Top 5 Sales Employees by Sales Amount (pervasive dashboard)
For more information about the new KPIs and pervasive dashboard, see
Predefined KPIs and Predefined Pervasive Dashboards, respectively.

2.1

2016-02-04
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·

In pervasive dashboards, using the new function of legend color, you can
now slice corresponding measure values from the measure axis in
comparison to the existing dimension that slices corresponding measure
values from the dimension axis. For more information about legend color,
see Using Legend Color.

·

In pervasive dashboards with one date-type dimension, you can now use
the new function of time slider for a clearer view of trends. For more
information about the time slider, see Using the Time Slider.

·

Pervasive dashboard now supports more calculation types: Cumulative
Sum, Minimum, Maximum, and Count. For more information, see Basic
Settings Tab.

Guide updated for SAP Business One 9.2 PL01, version for SAP HANA.
Changes are as follows:
·

In KPIs and pervasive dashboards, you can use -Current User- as a
filtering value for string type dimensions. If you choose this value, the
code of the logged-on user will be used as the filtering value. For more
information about using filters in KPIs and pervasive dashboards, see
Filter & Parameter Tab for KPIs and Filter & Parameter Tab for pervasive
dashboards.

·

In KPIs and pervasive dashboards, for date type dimensions, you can use
the updated Filter Editor window to define a dynamic time range that can
vary according to the time you run a KPI or pervasive dashboard. For
more information about using filters in KPIs and pervasive dashboards,
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Version
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Change
see Filter & Parameter Tab for KPIs and Filter & Parameter Tab for
pervasive dashboards.
·

For KPIs, you can add a new action type Open Dashboard (For the SAP
Business One Sales App). In the SAP Business One Sales app, for a KPI to
which you have added this type of action, you can tap the KPI to open the
linked pervasive dashboard. For more information, see Action: Open
Dashboard (For the SAP Business One Sales App).

·

For a pervasive dashboard, when you add only one dimension, the
dimension is of date type, and the time unit is Year, Year-Quarter, or YearMonth, in the SAP Business One Sales app, this pervasive dashboard will
have three time tabs at the bottom. For more information, see Basic
Settings Tab.

·

Pervasive analytics provide the following new predefined KPIs, pervasive
dashboards, and advanced dashboards, all of which appear in the SAP
Business One Sales app by default:
o Adv. Dashboard for SAP Business One Sales App - Curr. Sales EE
o Potential Amt of Open Opportunities - Curr. User (KPI)
o Potential Amt of Open Oppty by Stages - Curr. User (pervasive
dashboard)
o Sales Order Amount of This Month (LC) - Curr. User (KPI)
o Sales Order Amount by Mo./Qty/Yr (LC) - Curr. User (pervasive
dashboard)
o Top 5 Customers by Sales Amount - Curr. User (pervasive
dashboard)
o Top 5 Best Selling Items by Sales Amt - Curr. User (pervasive
dashboard)
o Adv. Dashboard for SAP Business One Sales App - Customer
o Sales Order Amount by Months (LC) (pervasive dashboard)
o Total Amount of Open Deliveries (LC) (KPI)
o Customer Balance (LC) (KPI)
o Top 5 Best Selling Items by Sales Amount (Mobile) (pervasive
dashboard)
For more information about the new contents, see Predefined KPIs,
Predefined Pervasive Dashboards, and Predefined Advanced
Dashboards, respectively.

·
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In the pervasive analytics designer, you cannot delete the predefined
contents.

2.2

2016-05-06

Guide updated with the link to the guides How to Work with SAP Business One
Sales, mobile app for iOS or How to Work with SAP Business One Sales, mobile
app for Android.

2.3

2016-08-19

Guide updated for SAP Business One 9.2 PL04, version for SAP HANA.
Changes are as follows:
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Change
·

The Filter Editor window for a date type dimension was enhanced. For
more information, see Filter and Parameter Tab for KPIs, and Filter and
Parameter Tab for pervasive dashboards.

·

In the pervasive analytics designer, you can now search for your KPIs,
dashboards, or advanced dashboards, and in the dashboard designer,
you can now search for measures or dimensions.

·

In the KPI designer, you can add a minus sign in front of the KPI value. For
more information, see Value Settings Tab.

·

In the KPI designer, you can customize the unit for the KPI value. For
more information, see Value Settings Tab.

·

You can now use the recommendation feature in the sidebars of sales
orders and sales quotations to view items recommended by SAP based
on your historic data. For more information, see Viewing
Recommendations in Sidebars.

·

You can now enjoy the Customer 360 feature to view customer-related
analysis. For more information, see Working with Customer 360.
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Introduction

Pervasive analytics for SAP Business One, version for SAP HANA enables you to access and visualize your data in
a customized way.
The application provides three analytic tools that can accelerate your decision making process, offering
immediate and fact-based answers to business questions.
·

Key Performance Indicators (KPIs): With queries and views, you can easily design KPIs and related actions
that are customized to your specific needs. You can view the KPI and use its actions in the advanced
dashboard or the cockpit.

·

Pervasive dashboard: With queries and views, you can easily design pervasive dashboards and related actions
that are customized to your specific needs. You can view the pervasive dashboard and use its actions in the
advanced dashboard or the cockpit.

·

Advanced dashboard: You can design advanced dashboards to contain various widgets. You can view the
advanced dashboard in pages and retrieve specific data using filters.

How to Work with Pervasive Analytics
Introduction
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Working with Key Performance Indicators
(KPIs)

A KPI helps you evaluate the status of business in an easy-to-view way. The pervasive analytics designer enables
you to design KPIs of your own based on the following:
·

Queries in SAP Business One, version for SAP HANA

·

Calculation views in the SAP HANA database

Note
o For a newly created company in SAP Business One 9.2, version for SAP HANA, the compatibility mode is
Off, and thus only calculation views are available.
o SAP Business One 9.2, version for SAP HANA companies upgraded from versions that have the
compatibility mode feature, will have the same settings for the compatibility mode as the previous
versions.
o The compatibility mode is On for SAP Business One 9.2, version for SAP HANA companies upgraded from
versions that:
o Do not have the compatibility mode feature
o Are initialized
Thus, they will have the previously provided analytic and attribute views.
o The compatibility mode is Off for SAP Business One 9.2, version for SAP HANA companies upgraded
from versions that:
o Do not have the compatibility mode feature
o Are not initialized
Thus, only calculation views are available.
For more information about the compatibility mode, look for the SAP Business One Administrator's Guide,
version for SAP HANA on sappartneredge.com.
In the pervasive analytics designer, you can also set up a link between your KPI and an advanced dashboard. Thus
the linked advanced dashboard will appear when you click the KPI in the Fiori-style cockpit or in an advanced
dashboard.

Note
For more information about the semantic layer data sources, look for the How to Work with Semantic
Layers guide on sappartneredge.com.

8
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2.1

Designing KPIs Using the Pervasive Analytics Designer

Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To grant authorizations for the pervasive
analytics designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose
Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations
window, select the user for whom you want to set authorizations, and under Analytics, in Pervasive Analytics
Designer select Full Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access this window.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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2.

On the left side of the Pervasive Analytics window, choose New KPI.

The KPI designer appears. The data source section on the left displays the following:
o All the system and customized SELECT queries.
o All the deployed calculation views in the SAP HANA database.

Note
o For a newly created company in SAP Business One 9.2, version for SAP HANA, the compatibility mode is
Off, and thus only calculation views are available.
o SAP Business One 9.2, version for SAP HANA companies upgraded from versions that have the
compatibility mode feature, will have the same settings for the compatibility mode as the previous
versions.
o The compatibility mode is On for SAP Business One 9.2, version for SAP HANA companies upgraded from
versions that:
o Do not have the compatibility mode feature
o Are initialized
Thus, they will have the previously provided analytic and attribute views.
o The compatibility mode is Off for SAP Business One 9.2, version for SAP HANA companies upgraded
from versions that:
o Do not have the compatibility mode feature
o Are not initialized

10
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Thus, only calculation views are available.
For more information about the compatibility mode, look for the SAP Business One Administrator's Guide,
version for SAP HANA on sappartneredge.com.
3.

On the left side of the KPI designer, in the data source section, select the query or view based on which you
want to design a KPI.
Its measures, dimensions, and parameters appear.
o Measures appear with the

label.

o String type dimensions appear with the
o Date type dimensions appear with the
o Parameters appear with the

label.
label.

label.

4.

On the Value Settings tab, specify various settings. For more information, see Value Settings Tab.

5.

[Optional] On the Filter and Parameter tab, specify filters and parameters. For more information, see Filter
and Parameter Tab.

Note
If you selected a measure from the KPI Balance Sheet Query, KPI Cash Flow Statement Query, or KPI
Profit And Loss Query view, you must add P_TemplateInternalKey as a parameter, and add the dimension
KPI Factor Internal Key or KPI Factor Name as a filter. For more information, see Filter and Parameter Tab
and Using Financial KPI Factors.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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6.

[Optional] If you are designing a KPI that consists of other KPIs, then on the Composite KPI tab, specify the
variables. For more information, see Composite KPI Tab.

Note
A KPI value is taken either from the KPI value box on the Value Settings tab or from the expression result
on the Composite KPI tab. Therefore, you cannot both specify a measure in the KPI value box on the Value
Settings tab and design a composite KPI on the Composite KPI tab.

12
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7.

[Optional] In the preview area, choose Status Displaying and define the display settings. For more
information, see Status Displaying Section.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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8.

[Optional] In the preview area, choose Action and add actions to the KPI. For more information, see Adding
Actions to KPIs.

9.

To save the KPI, in the upper left corner, choose
(Save); to save the KPI as a new one, if you opened an
existing KPI, in the upper left corner, choose
(Save As).

14
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2.1.1

Value Settings Tab

Procedure
On the Value Settings tab, perform the following:
1.

Specify the KPI name and description.
The KPI name appears in the upper left corner of the preview area. The KPI description appears as a tooltip
when your mouse cursor hovers over the KPI name.

2.

In the data source section, in a query or view, select a measure and drag it to the value box of the Set KPI
Value section.
The preview area is refreshed and the sum or average of the KPI value appears.
The name of the selected query or view appears in the From Data Source field at the bottom of the Set KPI
Value section.

3.

[Optional] In the data source section, in the same query or view, select a date dimension, and drag it to the
date dimension box of the Set KPI Value section.
The preview area is refreshed and the KPI value is calculated according to the date range you specified.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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4.

[Optional] In the Unit dropdown list of the Set KPI Value section, select the unit that you want to display under
the KPI value.
The preview area is refreshed and the selected unit appears beside the KPI value. If you customized the unit,
you must enter no more than five characters.

5.

In the Set KPI Goal section, perform the following to define a basic goal or an advanced goal.
o To define a basic goal, specify the name or description of the goal, and specify a number as the goal value.
o To define an advanced goal, specify the name or description of the goal. If you selected a measure from a
view as your KPI value, select a measure from any query as your goal value; if you selected a measure
from a query as your KPI value, select a measure from any query in the same query category as your goal
value.
The first value of the measure will be the goal value.

Note
For the advanced goal value, you cannot select a measure from queries with parameters.
An arrow may appear before the KPI value in the preview area, based on the KPI value and goal value:
o If the KPI value is greater than the goal value, an up arrow appears.

16
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o If the KPI value is equal to the goal value, nothing appears.

o If the KPI value is smaller than the goal value, a down arrow appears.

The preview area is refreshed as follows:
o The goal name and goal value appear in a tooltip when your mouse cursor hovers over the KPI value.
o The appropriate arrow appears before the KPI value.
o The color of the arrow and KPI value is updated. The color of the arrow and the KPI value are determined
by the settings in the Status Displaying section and the status of the Smaller Value Is Better checkbox.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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You can see the color change in the following screenshots when the settings in the Status Displaying
section are the same and the status of the Smaller Value Is Better checkbox is different.
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Note
If you have changed any default settings in the Status Displaying section since starting work on the KPI,
the status change of the Smaller Value Is Better checkbox will NOT determine the color of the arrow and
the KPI value. If you want to change the color of the KPI arrow and the KPI value, change the settings in
the Status Displaying section.
6.

[Optional] In the Set KPI Trend section, perform the following to define a basic trend or an advanced trend.
o To define a basic trend, select the trend type.

Example
For the month-over-month basis, the trend value will be the compared percentage between the KPI value
of this month and that of last month. For the month-over-same-month basis, the trend value will be the
compared percentage between the KPI value of this month and that of the same month last year.
o For an advanced trend, if you selected a measure from a view as your KPI value, select a measure from
any query as your trend value; if you selected a measure from a query as your KPI value, select a measure
from any query in the same query category as your trend value.
The first value of the measure will be the trend value.

Note
For the advanced trend value, you cannot select a measure from queries with parameters.
An arrow may appear before the trend value in the preview area based on the trend value:

Note
When the denominator in the trend calculation is not a positive number, the following appears in the trend
area.

How to Work with Pervasive Analytics
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o If the trend value is greater than zero, an up arrow appears.

o If the trend value is equal to zero, nothing appears.
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o If the trend value is less than zero, a down arrow appears.

The preview area is refreshed as follows:
o The trend name and trend value appear in a tooltip when your mouse cursor hovers over the KPI value.
o The trend value appears in the lower right corner of the preview area.
o The arrow appears before the trend value.
o The color of the arrow is updated. The color of the arrow is determined by the status of the Smaller Value
Is Better checkbox.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)
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You can see the color change in the following screenshots when the status of the Smaller Value Is Better
checkbox is different.
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Note
If you have changed any default settings in the Status Displaying section since starting work on the KPI,
the status change of the Smaller Value Is Better checkbox will not immediately refresh the preview area.
The color of the trend arrow will be refreshed the next time you open this KPI.
7.

[Optional] To make this KPI unavailable for display in the cockpit, select the Interim checkbox. This means
that the KPI will only be the component of other KPIs, and will not be available for display in the cockpit.

8.

[Optional] Select the Smaller Value Is Better checkbox to indicate that the smaller the value than the goal
value, the better the result, or that if the trend value is less than zero, the result is good. This checkbox
determines the color settings in the Status Displaying section, thus affecting the following:
o Color of the arrow before the trend value.
o Color of the following:
o Arrow before the KPI value (if the KPI value is not equal to the goal value)
o KPI value

Note
If you have changed any default settings in the Status Displaying section since starting work on the KPI,
the following will happen:
o The status change of the Smaller Value Is Better checkbox will not immediately refresh the color of
the trend arrow. The color of the trend arrow will be refreshed the next time you open this KPI.
o The status change of the Smaller Value Is Better checkbox will NOT determine the color of the KPI
arrow and the KPI value. If you want to change the color of the KPI arrow and the KPI value, change
the settings in the Status Displaying section.
9.

[Optional] Select the Minus Sign checkbox to add a minus sign in front of the KPI value. The status of this
checkbox, together with the settings in the Status Displaying section, determines the color of the following:
o Arrow before the KPI value (if the KPI value is not equal to the goal value)
o KPI value

2.1.2

Filter and Parameter Tab

Prerequisite
On the Value Settings tab, you have dragged a measure from a query or view to the value box of the Set KPI Value
section.

Procedure
·

For filters, perform the following:
1.

In the data source section, in the same query or view from which you dragged the KPI value, select a
dimension and drag it to the filter box.
The Filter Editor window appears.

How to Work with Pervasive Analytics
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2.

In the Filter Editor window, perform the following based on the type of the dimension:
o For a string type dimension, select a filtering value, or enter a filtering value and choose the Add Value
button.
The filtering value is added to the Active Filters section.
For string type dimensions, -Current User- appears as a filtering value. If you choose this value, the
code of the logged-on user will be used as the filtering value.

Note
When the KPI value filtered by certain filtering values has records in the database, then such and only
such filtering values appear in the list. If you want to use other filtering values, you need to enter them and
choose the Add Value button.
o For a date type dimension, define a time range.

24
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3.

To save the filter settings, in the Filter Editor window, choose the Add button.
The preview area is refreshed according to the added filters.

Note
If you selected a measure from views KPI Balance Sheet Query, KPI Cash Flow Statement Query, or KPI
Profit And Loss Query view, you must add P_TemplateInternalKey as a parameter, and add the dimension
KPI Factor Internal Key or KPI Factor Name as a filter. For more information, see Using Financial KPI
Factors.
·

For parameters, perform the following:
1.

In the data source section, in the same query or view from which you dragged the KPI value, select a
parameter and drag it to the parameter box.
The Parameter Editor window appears.

2.

In the Parameter Editor window, perform the following based on the type of the parameter:
o For a date type parameter, specify a default date.

o For a number type parameter, specify a default number.

o For a string type parameter, specify a default value.

3.

To save the parameter settings, choose the Add button.
The preview area is refreshed according to the added parameters.

How to Work with Pervasive Analytics
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Note
Some parameters are labeled with a red rectangle. To get a meaningful KPI value, you must drag those
parameters to the parameter box.

2.1.2.1

Using Financial KPI Factors

A financial KPI factor links a KPI and an item in the financial report templates. You define financial KPI factors in
the Financial KPI Factor - Setup window. To open this window, from the SAP Business One, version for SAP HANA
Main Menu, choose Administration → Setup → Financials →Financial KPI Factors.

SAP Business One, version for SAP HANA provides 28 predefined financial KPI factors.
In the KPI Balance Sheet Query, KPI Cash Flow Statement Query, and KPI Profit And Loss Query views, the
measures that are defined as the KPI values do not retrieve data directly from the database. Only after you
identify the financial report template in the KPI designer and set the dimension KPI Factor Internal Key or KPI
Factor Name as a filter, does the KPI value retrieve data from the financial report template item that is linked to
the financial KPI factor.
Using the financial KPI factors in KPIs consists of the following procedures:
1.

Link a financial KPI factor to an item in the financial report template.

2.

Identify the financial report template in the KPI designer.

26

PUBLIC
© 2016 SAP SE. All rights reserved.

How to Work with Pervasive Analytics
Working with Key Performance Indicators (KPIs)

3.

Set the dimension KPI Factor Internal Key or KPI Factor Name as a filter.

Prerequisite
Linked items of the financial report template contain values, and the values belong to the current year.

Procedure
To link a financial KPI factor to an item in the financial report template, follow the procedure below:
1.

From the SAP Business One, version for SAP HANA Main Menu, choose Financials → Financial Report
Templates.
The Financial Report Templates window appears.

2.

In the Financial Report Templates window, select a template from the Balance Sheet, Profit and Loss, or
Statement of Cash Flows report.
The template appears on the right.

3.

In the template, select an item whose data you want to use in the KPI.

How to Work with Pervasive Analytics
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4.

In the Financial KPI Factors section, in the Factor field, enter the factor code, or press T a b to select a factor.

5.

To save the link, in the Financial Report Templates window, choose the Update button.

Procedure
To identify the financial report template in the KPI designer, follow the procedure below:
1.

In the SAP Business One, version for SAP HANA menu bar, choose View → System Information.
When you hover your mouse over fields in windows, you can view system information in the left-hand corner
of the status bar.

2.

From the SAP Business One, version for SAP HANA Main Menu, choose Financials → Financial Report
Templates. From the Report dropdown list, select the required financial report.

3.

From the Template dropdown list, select the template.
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4.

Hover your mouse over the template name.

The system information appears in the status bar, and the first number is the template code.
5.

In the data source section of the KPI designer, in the same query or view from which you dragged the KPI
value, select P_TemplateInternalKey, and drag it to the parameter box.

6.

In the Parameter Editor window, enter the template code that you got from the system information of the
template.

7.

To identify the financial report template in the KPI designer, choose the Add button.

How to Work with Pervasive Analytics
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Procedure
To set the dimension KPI Factor Internal Key or KPI Factor Name as a filter, follow the procedure below:
1.

In the data source section, in the same query or view from which you dragged the KPI value, select KPI Factor
Internal Key or KPI Factor Name, and drag it to the filter box.
The Filter Editor window appears, displaying all the financial KPI factors that contain values.

2.

In the Filter Editor window, select the available financial KPI factor, or enter a financial KPI factor code (if you
dragged the KPI Factor Internal Key dimension) or financial KPI factor name (if you dragged the KPI Factor
Name dimension), and choose the Add Value button.
The financial KPI factor is added to the Active Filters section.

3.

To save the filter settings, choose the Add button.
The preview area is refreshed and the KPI value is retrieved from the financial report template item.
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2.1.3

Composite KPI Tab

The data source section of the Composite KPI tab displays all the KPIs in the database, including interim KPIs.

Note
Nested composite KPI is not supported. Example of a nested composite KPI is as follows:
Expression=K01+K02, K02=K03+04. You can use the following instead: Expression= K01+K03+K04.
The following expressions are supported: "+" (plus sign), "-" (minus sign), "*" (multiply sign), "/" (divide sign), "()"
(bracket).

Procedure
On the Composite KPI tab, perform the following:
1.

From the KPI list section, drag a KPI to the variable box.
The dragged KPI is labeled as a variable.

2.

In the Expression field, specify the expression using the variables.
The preview area is refreshed and the result of the calculated expression appears as the KPI value.
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2.1.4

Status Displaying Section

Procedure
In the Status Displaying section, perform the following:
1.

Select the separator type.

2.

In the two value boxes, perform the following based on the separator type you selected:
o If you selected Specific Value, enter specific values to act as the separators for different colors.
o If you selected Ratio of KPI to Goal, enter numbers with percentage symbols to act as the separators for
different colors.

3.

In the three colored dropdown lists, select the colors to represent the three separated parts.

4.

You can click the color bar to add a separator.

5.

To delete the separator, choose
button.

(Delete) beside the value box; to save the display settings, choose the OK

The preview area is refreshed. The color of the KPI and the arrow before the KPI value (if the KPI value is not
equal to the goal value) is updated.
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2.1.5

Adding Actions to KPIs

To access the action section of a KPI, in the lower right corner of the preview area, choose Action. The action
section displays the action that you have defined.

Note
You can add only one action for one KPI.

Procedure
To add actions to KPIs, follow the procedure below.
1.

In the action section of a KPI, choose

(Add a New Action) beside Actions To Be Triggered.

The edit window appears.

2.

You can add one type of action. For more information, see the following section.

3.

To save the action, in the edit window, choose the OK button; to delete the action, in the action section,
choose (Remove) beside the action.
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2.1.5.1

Action: Open Advanced Dashboard

In the Fiori-style cockpit or an advanced dashboard, for a KPI to which you have added this type of action, click the
KPI to open the linked advanced dashboard.

Procedure
To add action type Open Advanced Dashboard, follow the procedure below:
1.

In the edit window of actions, select the Open Advanced Dashboard radio button.

2.

In the Action Name field, specify the action name.

3.

In the Target Adv. Dashboard dropdown list, select the advanced dashboard that you want to open. You can
link the KPI to only one advanced dashboard with one action, and you can add only one action to one KPI.

4.

To save the action, choose the OK button.

2.1.5.2

Action: Open Dashboard (For the SAP Business One
Sales App)

In the SAP Business One Sales app, for a KPI to which you have added this type of action, tap the KPI to open the
linked pervasive dashboard.
For more information about customizing the advanced dashboard to be displayed in the SAP Business One Sales
app, see Predefined Advanced Dashboards.
For more information about the mobile app, look for the guides How to Work with SAP Business One Sales, mobile
app for iOS or How to Work with SAP Business One Sales, mobile app for Android on sappartneredge.com.

Note
This action takes effect only in the SAP Business One Sales app.

Procedure
To add the action type Open Dashboard (For the SAP Business One Sales App), follow the procedure below:
1.

In the edit window of actions, select the Open Dashboard (For the SAP Business One Sales App) radio button.

2.

In the Action Name field, specify the action name.

3.

In the Target. Dashboard dropdown list, select the pervasive dashboard that you want to open. You can link
the KPI to only one pervasive dashboard with one action, and you can add only one action to one KPI.

4.

To save the action, choose the OK button.
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2.2

Viewing KPIs in the Cockpit

In the cockpit, you can view predefined KPIs as well as the KPIs that are designed using the pervasive analytics
designer.

Prerequisites
·

Your system administrator or key user has done the following:
o Enabled the cockpit at company level by selecting the Cockpit radio button on the Cockpit tab of the
General Settings window. To open this window, from the SAP Business One, version for SAP HANA Main
Menu, choose Administration → System Initialization → General Settings.
o Assigned the user authorizations for Cockpit & Widget. To grant the Cockpit & Widget authorizations to
users, from the SAP Business One, version for SAP HANA Main Menu, choose Administration → System
Initialization → Authorizations → General Authorizations. In the Authorizations window, select the user to
whom you want to grant the authorizations, and in Cockpit & Widget, select Full Authorization.

·

You have enabled the cockpit at user level by choosing Tools →Cockpit →Enable My Cockpit in the SAP
Business One, version for SAP HANA menu bar.

·

You have authorizations for the KPI that you want to view. To set authorizations for KPIs to users, from the
SAP Business One, version for SAP HANA Main Menu, choose Administration → System Initialization →
Authorizations → General Authorizations. In the Authorizations window, select the user to whom you want to
grant the authorization, and in Analytics → Content → KPI, select Full Authorization for the KPIs for which you
want to grant authorization.

Procedure
1.

From the SAP Business One, version for SAP HANA navigation panel on the left side of the window, under My
Cockpit, select the cockpit you want to use.
The cockpit appears.

2.

In the navigation panel, choose Widget Gallery → General Widgets.

3.

Select KPI Widget and drag it into the open cockpit area.
A window appears.

4.

To add a KPI to your cockpit, in the upper right section of the window, choose

5.

From the dropdown list, choose Settings.

(Tools).

The Select KPI window appears, listing all the KPIs for which you have authorizations.
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6.

To add one or more KPIs to the cockpit, select the appropriate checkbox.

7.

To confirm your choices, choose the OK button.
The selected KPIs appear.

2.3

Viewing KPIs in the Fiori-Style Cockpit

For more information about viewing KPIs in the Fiori-style cockpit, look for the How to Work with the Fiori-Style
Cockpit guide on sappartneredge.com.
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2.4

Managing KPIs in the Pervasive Analytics Designer

Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To grant authorizations for the pervasive
analytics designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose
Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations
window, select the user for whom you want to set authorizations, and under Analytics, in Pervasive Analytics
Designer, select Full Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access this window.
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2.

In the My KPIs section, you can find all the KPIs, for which you can perform the following:
o Select each KPI to view its contents.
o To delete a KPI, hover your mouse over the relevant KPI, choose the
the system message.

2.5

icon, and choose the Yes button in

Predefined KPIs
Note
The predefined KPIs in the four localizations (CN, DE, GB, US) are available for the following charts of
accounts:
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Chart of Accounts

Local Settings

M - 股份有限公司会计制度

P.R.China/Hong-Kong

C - US_CoA

United States Of America/Puerto Rico
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Chart of Accounts

Local Settings

N - SKR03

Germany

G - GB_CoA

United Kingdom/Ireland

Note
The predefined KPIs in the localization All are available for all charts of accounts in all localizations.
KPIs can differ among companies, depending on industries and company goals. The 57 predefined KPIs are the
most commonly used ones that reflect a company's financial performances.
You can focus on individual KPIs to measure the performance at a specific requirement. You can also group the
KPIs in a certain area to get a whole and comprehensive picture of your company's financial performances.
The predefined KPIs are in the following areas:
·

Working capital management:
Working capital is the amount of a company's current assets minus its current liabilities. The working capital
ensures that the company is able to carry out its day-to-day operations, as well as to satisfy its maturing
short-term debt and the upcoming operational expenses.
The following predefined KPIs help you measure and monitor your company's working capital:
o Accounts Payable (CN, DE, GB, US)
o Accounts Receivable (CN, DE, GB, US)
o Cash (CN, DE, GB, US)
o CCC (CN, DE, GB, US)
o Customer Balance (LC)
o DIO (CN, DE, GB, US)
o DPO (CN, DE, GB, US)
o DSO (CN, DE, GB, US)
o Inventory (CN, DE, GB, US)
o Inventory Turnover (CN, DE, GB, US)
o Inventory Turnover (Year)
o OC (CN, DE, GB, US)
o Total Amount of Open Deliveries (LC)
o Working Capital (CN, DE, GB, US)

·

Profitability ratios:
Profitability measures a company's ability to generate earnings considering sales, assets and equity. It
highlights a company's efficiency for gaining profits. It is important to company owners and investors.
The following predefined KPIs help you define and measure your company's profitability:
o Asset Turnover (CN, DE, GB, US)
o Gearing Ratio (CN, DE, GB, US)
o Gross Profit (CN, DE, GB, US)
o Gross Profit (LTD)
o Gross Profit (YTD)
o Gross Profit Margin (CN, DE, GB, US)
o Gross Profit Margin (YTD)
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o Net Profit Margin (CN, DE, GB, US)
o Operating Margin (CN, DE, GB, US)
o ROE (CN, DE, GB, US)
·

Liquidity ratios:
Liquidity is a company's ability to pay off its short-term debts. It shows the proportion by which the current
liabilities are covered by liquid assets. In general, the greater the coverage is, the more likely it is that the
company is able to pay the debts when they fall due, and still be able to fund ongoing operations.
The following predefined KPIs reflect your company's liquidity:
o Cash Ratio (By Profit) (CN, DE, GB, US)
o Cash Ratio (By Revenue) (CN, DE, GB, US)
o Current Ratio (CN, DE, GB, US)
o Quick Ratio (CN, DE, GB, US)

·

Debt Ratios (CN, DE, GB, US):
Debit ratio is calculated as a company's total debts to its total assets, which quantifies how leveraged a
company is. It indicates how much a company relies on the debts to finance its assets.
The higher the debt ratio is, the more risky the operations are; this means that the company needs to bear a
higher proportion of cash flow that is generated from operations to pay the interests on its debts.

·

Financial statements:
Financial statements are formal records that reflect a company's financial activities and performances in a
financial period. The information is presented in a manner that is easy to understand. Typically, the following
statements are included:
o Balance Sheet
o Cash Flow Statement
o Profit and Loss Statement
A company needs to prepare and show its financial statements to reveal its financial activities and
performances. The public and stakeholders thus can make their financial decisions based on the financial
statements.
The following predefined KPIs show the main and important statement items:
o Accounts Payable (CN, DE, GB, US)
o Accounts Receivable (CN, DE, GB, US)
o Cash (CN, DE, GB, US)
o COGS (CN, DE, GB, US)
o Gross Profit (CN, DE, GB, US)
o Inventory (CN, DE, GB, US)
o Net Cash Flow (CN, DE, GB, US)
o Net Cash Flow (Financial) (CN, DE, GB, US)
o Net Cash Flow (Investment) (CN, DE, GB, US)
o Net Cash Flow (Operating) (CN, DE, GB, US)
o Net Profit (CN, DE, GB, US)
o Total Assets (CN, DE, GB, US)
o Total Current Assets (CN, DE, GB, US)
o Total Current Liabilities (CN, DE, GB, US)
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o Total Equity (CN, DE, GB, US)
o Total Liabilities (CN, DE, GB, US)
·

Daily operation indexes:
The following predefined KPIs help you monitor and evaluate some important parts or aspects of your
company's daily operations:
o Expense 1 (DE, GB, US)
o Expense 2 (DE, GB, US)
o Inventory Value
o Operating Cost (DE, GB, US)
o Operating Income (CN, DE, GB, US)
The following predefined KPIs help you monitor and evaluate the important parts or aspects from the sales
side:
o Average Delivery Variance Days
o Average Fulfillment Days for a Sales Order
o Net Sales Revenue (CN, DE, GB, US)
o Number of Open Deliveries
o Number of Open Sales Orders
o Number of Open Sales Quotations
o Number of Open Service Calls
o On-Time Delivery Rate
o Open Amount of Deliveries
o Outbound Inventory Value
o Receivables Overdue
o Sales Order Amount of This Month (LC) - Curr. User
o Sales Return Amount
o Sales Return Amount for This Year
o Total Receivable Amount
o Total Receivable Amount YTD
o Total Sales Amount
o Total Sales Amount (LTD)
o Total Sales Amount (YTD)
The following predefined KPIs help you monitor and evaluate the important parts or aspects from the
purchasing side:
o Average Fulfillment Days for a Purchase Order
o Average Receipt Variance Days
o Goods Return Amount
o GRPO Not Invoiced
o Inbound Inventory Value
o Payables Overdue
o Total Payable Amount
o Total Purchase Amount
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·

Customer relationship management (CRM):
o Churn Probability
o Credit Limit Deviation
o Opportunity Win Rate (LTD)
o Potential Amt of Open Opportunities
o Potential Amt of Open Opportunities - Curr. User
o Weighted Amount of All Open Opportunities (LC)

For a complete list of predefined KPIs, see the table below.

Note
For more information about financial KPI factors, see Using Financial KPI Factors.

Note
To see a specific query, in the menu bar, choose Tools → Queries → Query Manager. For more information
about the query manager, see Query Manager in the online help documentation.
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Accounts
Payable

Accounts payable amount on the current
day

Financial KPI
factor Accounts
Payable (factor
007)

Yes

CN, DE, GB,
US

Accounts
Receivable

Accounts receivable amount on the
current day

Financial KPI
factor Accounts
Receivables (factor
003)

Yes

CN, DE, GB,
US

Asset
Turnover

Asset turnover ratio up to today in the
current month, reflecting the efficiency of
a company's use of its assets in
generating net sales revenue to the
company

KPI Net Sales
Revenue ÷ KPI
Total Assets

No

CN, DE, GB,
US

Average
Delivery
Variance Days

Average (YTD) number of days between
the posting date of the delivery and the
due date of the source sales order. The
KPI covers orders within the current year
according to their document dates.

Calculation view
Statistics of OnTime Delivery

No

All

Average
Fulfillment
Days for a
Purchase
Order

Average (YTD) number of days it takes to
receive products since the purchase
order is created. The KPI covers orders
within the current year according to their
document dates. Fulfillment days per
purchase order = posting date of GRPO posting date of purchase order

Calculation view
Purchase Order
Fulfillment Cycle
Time Query

No

All

Average
Fulfillment

Average (YTD) number of days it takes to
deliver products since the sales order is

Calculation view
Sales Order

No

All
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Days for a
Sales Order

created. The KPI covers orders within the
current year according to their document
dates. Fulfillment days per sales order =
posting date of delivery - posting date of
sales order

Fulfillment Cycle
Time Analysis

Average
Receipt
Variance Days

Average (YTD) number of days between
the posting date of goods receipt PO and
the due date of the source purchase
order. The KPI covers orders within the
current year according to their document
dates.

Calculation view
Statistics of OnTime Receipt

No

All

Cash

Total amount of cash and monetary
capital on the current day

Financial KPI
factor Cash (factor
001)

Yes

CN, DE, GB,
US

Cash Ratio
(By Profit)

Net cash flow spent on operating
activities as a percentage of the net profit
gained. The value is up to today in the
current month.

KPI Net Cash flow
(Operating) ÷ KPI
Net Profit

No

CN, DE, GB,
US

Cash Ratio
(By Revenue)

Net cash flow spent on operating
activities as a percentage of the net sales
revenue achieved. The value is up to
today in the current month.

KPI Net Cash flow
(Operating) ÷ KPI
Net Sales Revenue

No

CN, DE, GB,
US

CCC

Cash conversion cycle up to today in the
current month.

KPI DIO + KPI DSO
– KPI DPO

No

CN, DE, GB,
US

Calculation view
Customer Churn
Query

No

All

Cash conversion cycle, the average
number of days it takes for a company to
convert resource inputs into cash flows
Churn
Probability

Average churn rate of all customers
based on sales orders and A/R invoices.
In Customer 360, this KPI displays the
churn rate of the relevant customer.

Note
To view the rate and to update it
with the latest data in your
company database, in a web
browser, navigate to the following
URL: https://<Server
Address>:<Port>/Predictiv
eAnalysis, log on to the
company you are working with,
and choose the Refresh Now
button.
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

The URL supports the following
Web browsers: Google Chrome,
Microsoft Edge, Apple Safari, and
Mozilla Firefox.
COGS

Costs of goods sold up to today in the
current month

Financial KPI
factor COGS
(factor 015)

Yes

CN, DE, GB,
US

Credit Limit
Deviation

Total of the following of all customers:

User-defined
query Credit Limit
Deviation

No

All

In the Business Partner Master Data
window, Credit Limit on the Payment
Terms tab minus Account Balance minus
Deliveries minus Orders.
In Customer 360, this KPI displays the
result for the relevant customer.

Current Ratio

The ratio between the total current assets
and total current liabilities of a company
on the current day

KPI Total Current
Assets ÷ KPI Total
Current Liabilities

No

CN, DE, GB,
US

Customer
Balance (LC)

The account balance of customers. The
data is taken from the Account Balance
field of the Business Partner Master Data
window of customers.

User-defined
query Balance Due

No

All

In the SAP Business One Sales app, this
KPI appears on the General tab of
customers by default, and displays the
account balance of the specific customer.
For more information about customizing
the advanced dashboard to be displayed
in the SAP Business One Sales app, see
Predefined Advanced Dashboards.
Debt Ratio

The percentage of a company's assets
that are provided via debt on the current
day

KPI Total Liabilities
÷ KPI Total Assets

No

CN, DE, GB,
US

DIO

Days of inventory outstanding up to today
in the current month.

KPI Inventory ÷ KPI
COGS × 30

No

CN, DE, GB,
US

KPI Accounts
Payable ÷ KPI
COGS × 30

No

CN, DE, GB,
US

Days of inventory outstanding, the
average number of days a company takes
to sell its inventory.
DPO

Days of payable outstanding up to today
in the current month.
Days of payable outstanding, the average
number of days a company takes to pay
its suppliers.
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

DSO

Days of sales outstanding up to today in
the current month.

KPI Accounts
Receivable ÷ KPI
Net Sales Revenue
× 30

No

CN, DE, GB,
US

Days of sales outstanding, the average
number of days a company takes to
collect its account receivables
Expense 1

Expense amount that needs to be
deducted from operating income for
generating net profit

Financial KPI
factor Expense 1
(factor 023)

Yes

DE, GB, US

Expense 2

Expense amount that needs to be
deducted from operating income for
generating net profit

Financial KPI
factor Expense 2
(factor 024)

Yes

DE, GB, US

Gearing Ratio

The proportion of debt to equity on the
current day

KPI Total Liabilities
÷ KPI Total Equity

No

CN, DE, GB,
US

Goods Return
Amount

Goods return amount in the current
month

User-defined
query Goods
Return Amount

No

All

Gross Profit

Gross profit amount gained up to today in
the current month

Financial KPI
factor Gross Profit
(factor 016)

No

CN

KPI Net Sales
Revenue – KPI
COGS

DE, GB, US

Gross Profit
(LTD)

Gross profit amount gained until today

Calculation view
Profitability
Analysis

No

All

Gross Profit
(YTD)

Gross profit amount gained in this year so
far

Calculation view
Profitability
Analysis

No

All

Gross Profit
Margin

Gross profit margin up to today in the
current month

KPI Gross Profit ÷
KPI Net Sales
Revenue

No

CN, DE, GB,
US

Gross Profit
Margin (YTD)

Gross profit amount divided by net sales
amount in this year so far

Calculation view
Profitability
Analysis

No

All

GRPO Not
Invoiced

Goods receipt of purchase order not
invoiced in the current month

User-defined
query GRPO Not
Invoiced

No

All

Inbound
Inventory
Value

Inbound inventory value in the current
month

User-defined
query Inbound
Inventory Value

No

All
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Inventory

Inventory amount on the current day

Financial KPI
factor Inventory
(factor 002)

Yes

CN, DE, GB,
US

Inventory
Turnover

Inventory turnover ratio up to today in the
current month

KPI COGS ÷ KPI
Inventory

No

CN, DE, GB,
US

Inventory
Turnover
(Year)

Inventory turnover of the last 12 months

User-defined
query Inventory
Turnover

No

All

Inventory
Value

Inventory value on the current day

User-defined
query Inventory
Value

No

All

Net Cash Flow

Net cash flow amount up to today in the
current month

Financial KPI
factor Net Cash
Flow (factor 028)

No

CN, DE, GB,
US

Net Cash Flow
(Financial)

Net cash flow amount spent on financing
activities up to today in the current month

Financial KPI
factor Net Cash
Flow (Financing)
(factor 027)

No

CN, DE, GB,
US

Net Cash Flow
(Investment)

Net cash flow amount spent on investing
activities up to today in the current month

Financial KPI
factor Net Cash
Flow (Investing)
(factor 026)

No

CN, DE, GB,
US

Net Cash Flow
(Operating)

Net cash flow amount spent on operating
activities up to today in the current month

Financial KPI
factor Net Cash
Flow (Operating)
(factor 025)

No

CN, DE, GB,
US

Net Profit

Net profit amount gained up to today in
the current month

Financial KPI
factor Net Profit
(factor 020)

No

CN

KPI Operating
Income – KPI
Expense 1 – KPI
Expense 2

46

DE, GB, US

Net Profit
Margin

Net profit margin up to today in the
current month

KPI Net Profit ÷
KPI Net Sales
Revenue

No

CN, DE, GB,
US

Net Sales
Revenue

Net sales revenue amount achieved up to
today in the current month

Financial KPI
factor Net Sales
Revenues (factor
012)

No

CN, DE, GB,
US
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Number of
Open
Deliveries

Total number of deliveries whose status is
Open.

User-defined
query Number of
Open Deliveries

No

All

Number of
Open Sales
Orders

Total number of sales orders whose
status is Open.

User-defined
query Number of
Open Sales Orders

No

All

Number of
Open Sales
Quotations

Total number of sales quotations whose
status is Open.

User-defined
query Number of
Open Sales
Quotations

No

All

Number of
Open Service
Calls

Total number of service calls whose
status is not Closed.

User-defined
query Number of
Open Service Calls

No

All

OC

Operating cycle up to today in the current
month.

KPI DSO+ KPI DIO

No

CN, DE, GB,
US

Calculation view
On-Time Delivery
Analysis

No

All

Calculation view
Delivery Header

No

All

In Customer 360, this KPI displays the
number for the relevant customer.

In Customer 360, this KPI displays the
number for the relevant customer.

In Customer 360, this KPI displays the
number for the relevant customer.

In Customer 360, this KPI displays the
number for the relevant customer.

Operating cycle, the average number of
days a company takes in realizing its
inventories in cash, equaling the time
taken in selling inventories plus the time
taken in recovering cash from trade
receivables
On-Time
Delivery Rate

The total of the following:
The result of the number of on-time
delivered sales orders divided by the
number of all delivered sales orders to
each business partner.
This KPI covers sales orders within this
year according to their document dates.
The deliveries whose posting dates are
earlier than or equal to the posting dates
of sales orders are considered as on-time
deliveries.
In Customer 360, this KPI displays the
rate for the relevant customer.

Open Amount
of Deliveries

Total open amount of all deliveries
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Operating
Cost

Operating cost generated up to today in
the current month

Financial KPI
factor Operating
Costs (factor 017)

Yes

DE, GB, US

Operating
Income

Operating income gained up to today in
the current month

Financial KPI
factor Operating
Income (factor
018)

No

CN

KPI Gross Profit –
KPI Operating Cost

DE, GB, US

Operating
Margin

Operating margin up to today in the
current month

KPI Operating
Income ÷ KPI Net
Sales Revenue

No

CN, DE, GB,
US

Opportunity
Win Rate
(LTD)

The result of the number of won
opportunities divided by the number of all
opportunities until today

Calculation view
Opportunity Win
Rate Analysis

No

All

Outbound
Inventory
Value

Outbound inventory value in the current
month

User-defined
query Outbound
Inventory Value

No

All

Payables
Overdue

Payables overdue up to today

(total Balance Due
– total Future
Remit) in the
Vendor Liabilities
Aging report

No

All

Potential Amt
of Open
Opportunities

The total potential amount of all open
opportunities whose start dates are
within this year. The data is taken from
the Potential Amount field on the Potential
tab of the Opportunity window.

Calculation view
Opportunities

No

All

Potential Amt
of Open
Opportunities
- Curr. User

The total potential amount of all open
opportunities of the currently logged-on
sales employee. The data is taken from
the Potential Amount field on the Potential
tab of the Opportunity window of the
currently logged-on sales employee.

User-defined
query Opportunity

No

All

In the SAP Business One Sales app, this
KPI appears in the KPI screen by default.
For more information about customizing
the advanced dashboard to be displayed
in the SAP Business One Sales app, see
Predefined Advanced Dashboards.
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Quick Ratio

An indication of a company's ability to use
its near cash or quick assets to extinguish
or retire its current liabilities immediately
on the current day

(KPI Cash + KPI
Accounts
Receivable) ÷ KPI
Total Current
Liabilities

No

CN, DE, GB,
US

Receivables
Overdue

Receivables overdue up to today

(total Balance Due
– total Future
Remit) in the
Customer
Receivables Aging
report

No

All

ROE

Return on equity, an indication of a
company's efficiency at generating profits
from every unit of its total equity up to
today in the current month

KPI Net Profit ÷
KPI Total Equity

No

CN, DE, GB,
US

Sales Order
Amount of
This Month
(LC) - Curr.
User

The total sales order amount of this
month of the currently logged-on sales
employee. The data is taken from the
Total field of the Sales Order window
whose posting date is within the current
month of the currently logged-on sales
employee.

User-defined
query Sales Order

No

All

In the SAP Business One Sales app, this
KPI appears in the KPI screen by default.
For more information about customizing
the advanced dashboard to be displayed
in the SAP Business One Sales app, see
Predefined Advanced Dashboards.
Sales Return
Amount

Sales return amount in the current month

User-defined
query Sales Return
Amount

No

All

Sales Return
Amount for
This Year

Total amount of sales returns whose
posting dates are within this year

Calculation view
Return Header

No

All

Total Amount
of Open
Deliveries (LC)

The total amount of all open deliveries.
The data is taken from the Total field of
the Delivery window whose status is
Open.

User-defined
query Sales Order

No

All

In the SAP Business One Sales app, this
KPI appears on the General tab of
customers by default, and displays the
total amount of all open deliveries of the
specific customer.
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

For more information about customizing
the advanced dashboard to be displayed
in the SAP Business One Sales app, see
Predefined Advanced Dashboards.
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Total Assets

Total assets on the current day

Financial KPI
factor Total Assets
(factor 006)

No

CN, DE, GB,
US

Total Current
Assets

Total current assets amount on the
current day

Financial KPI
factor Current
Assets (factor
005)

Yes

CN, DE, GB,
US

Total Current
Liabilities

Total current liabilities amount on the
current day

Financial KPI
factor Current
Liabilities (factor
008)

Yes

CN, DE, GB,
US

Total Equity

Total equity on the current day

Financial KPI
factor Total Equity
(factor 011)

No

CN, DE, GB,
US

Total
Liabilities

Total liabilities on the current day

Financial KPI
factor Total
Liabilities (factor
010)

No

CN, DE, GB,
US

Total Payable
Amount

Total payable amount in the current
month

User-defined
query Total
Payable Amount

No

All

Total
Purchase
Amount

Total purchase amount in the current
month

User-defined
query Total
Purchase Amount

No

All

Total
Receivable
Amount

Total receivable amount in the current
month

User-defined
query Total
Receivable Amount

No

All

Total
Receivable
Amount YTD

Total receivable amount in this year so far

Calculation view
Customer
Receivables Aging

No

All

Total Sales
Amount

Total sales amount in the current month

User-defined
query Total Sales
Amount

No

All

Total Sales
Amount (LTD)

Total sales amount until today

Calculation view
Profitability
Analysis

No

All
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KPI Name

KPI Description

Data Source

Interim
or Not

Localization

Total Sales
Amount (YTD)

Total sales amount in this year so far

Calculation view
Profitability
Analysis

No

All

Weighted
Amount of All
Open
Opportunities
(LC)

Total (YTD) weighted amount of all open
sales opportunities displayed in the local
currency. The KPI covers opportunities
within the current year according to their
start dates.

Calculation view
Opportunity Win
Rate Analysis

No

All

Working
Capital

Total working capital up to the current
day

KPI Cash + KPI
Accounts
Receivable + KPI
Inventory – KPI
Accounts Payable

No

CN, DE, GB,
US
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3

Working with Pervasive Dashboards

The pervasive analytics designer enables you to design pervasive dashboards of your own based on the following:
·

Queries in SAP Business One, version for SAP HANA

·

Calculation views in the SAP HANA database

Note
o For a newly created company in SAP Business One 9.2, version for SAP HANA, the compatibility mode is
Off, and thus only calculation views are available.
o SAP Business One 9.2, version for SAP HANA companies upgraded from versions that have the
compatibility mode feature, will have the same settings for the compatibility mode as the previous
versions.
o The compatibility mode is On for SAP Business One 9.2, version for SAP HANA companies upgraded from
versions that:
o Do not have the compatibility mode feature
o Are initialized
Thus, they will have the previously provided analytic and attribute views.
o The compatibility mode is Off for SAP Business One 9.2, version for SAP HANA companies upgraded
from versions that:
o Do not have the compatibility mode feature
o Are not initialized
Thus, only calculation views are available.
For more information about the compatibility mode, look for the SAP Business One Administrator's Guide,
version for SAP HANA on sappartneredge.com.
In the pervasive analytics designer, you can also add the following types of actions to pervasive dashboards. For
more information, see Adding Actions to Pervasive Dashboards.
·

Link the pervasive dashboards to SAP Business One, version for SAP HANA windows, and the pervasive
dashboards will appear in sidebars.

·

Open SAP Business One, version for SAP HANA windows.

·

Trigger enterprise search.

·

Open advanced dashboards.

The actions will appear when you right-click the data of pervasive dashboards in the Fiori-style cockpit or an
advanced dashboard.

Note
For more information about the semantic layer data sources, look for the How to Work with Semantic
Layers guide on sappartneredge.com.
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3.1

Designing Pervasive Dashboards Using the Pervasive
Analytics Designer

For more information about creating crystal dashboards for SAP Business One, version for SAP HANA using SAP
Crystal Dashboard Design, look for the How to Develop Your Own Dashboards guide on sappartneredge.com.

Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To set authorizations for the pervasive analytics
designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose Administration →
System Initialization → Authorizations → General Authorizations. In the Authorizations window, select the user
for whom you want to set authorizations, and under Analytics, in Pervasive Analytics Designer, select Full
Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access the window.
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2.

On the left side of the Pervasive Analytics window, choose New Dashboard.
The dashboard designer appears.
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3.

In the upper left corner of the dashboard designer, choose

(Select Base Data Source).

The Select Base Data Source window appears, displaying the following:
o All the system and customized SELECT queries
o All the deployed calculation views in the SAP HANA database

Note
o For a newly created company in SAP Business One 9.2, version for SAP HANA, the compatibility mode is
Off, and thus only calculation views are available.
o SAP Business One 9.2, version for SAP HANA companies upgraded from versions that have the
compatibility mode feature, will have the same settings for the compatibility mode as the previous
versions.
o The compatibility mode is On for SAP Business One 9.2, version for SAP HANA companies upgraded from
versions that:
o Do not have the compatibility mode feature
o Are initialized
Thus, they will have the previously provided analytic and attribute views.
o The compatibility mode is Off for SAP Business One 9.2, version for SAP HANA companies upgraded
from versions that:
o Do not have the compatibility mode feature
o Are not initialized
Thus, only calculation views are available.
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For more information about the compatibility mode, look for the SAP Business One Administrator's Guide,
version for SAP HANA on sappartneredge.com.
4.

In the Select Base Data Source window, select the query or view based on which you want to design a
pervasive dashboard. The right side of the window displays the details and up to 20 results.
[Optional] If you select a query, to open the query, choose the Edit Data Source button.

5.

In the Select Base Data Source window, choose the OK button.

If you selected a query, the Measures area displays numerical columns of the query, and the Dimensions area
displays non-numerical columns of the query.
If you selected a view, the Measures area displays the measures and calculated measures of analytic views, or
measures of calculation views, and the Dimensions area displays the attributes of views.
6.

56

On the Basic Settings tab, specify the basic settings of the pervasive dashboard. For more information, see
Basic Settings Tab.
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7.

[Optional] On the Filter and Parameter tab, specify filters and parameters. For more information, see Filter
and Parameter Tab .
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8.

[Optional] In the dashboard result area, you can perform the following:
o Select a strategy type to perform data analysis. For more information, see Using Strategies in the
Dashboard Designer.
o Choose Action and add actions to the pervasive dashboard. For more information, see Adding Actions to
Pervasive Dashboards.
o Enable the time slider for displaying time-related data. For more information, see Using the Time Slider.

9.

To save the dashboard, in the upper left corner, choose
(Save); to save the dashboard as a new one, if you
opened an existing dashboard, in the upper left corner, choose
(Save As).

3.1.1

Basic Settings Tab

On the Basic Settings tab of the dashboard designer, drag the required measures and dimensions to the target
areas to design your own dashboard. During your design process, the dashboard on the right displays real-time
results.
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Procedure
On the Basic Settings tab, you can perform the following:
·

For target measures, you can perform the following:
o Select a calculation method for the measures: Sum, Cumulative Sum, Minimum, Maximum, Average,
Count, or Original. To do this, click the measure, and select Calculation.

Note
Calculation method Original is not supported when you define a legend color. For more information about
legend colors, see Using Legend Color.
o Sort the data of the measures: Ascending, Descending, or No Sorting. To do this, either click the measure,
and select Sort, or click the sort icon on the right of the measure.
o Change the legend name in the dashboard. To do this, click the measure, select Rename, enter the name,
and click anywhere else in the dashboard.
o Drag measures up and down to change their display order in the legend.
·

For target dimensions, you can perform the following:
o Set the number of top values from 5 to 300 using the Limit to Top bar.

Note
For strategies K-Means Clustering and ABC Analysis, the Limit to Top bar is not available.

Note
When the time slider is enabled, the Limit to Top bar is not available. For more information about the time
slider, see Using the Time Slider.
o Drag dimensions up and down to change their display order on the dimension axis.
o For dimensions of date type, select the time unit to display in the dashboard: Year, Year-Quarter, YearMonth, Year-Week, Quarter, Month, Week, and Date.

Note
The Enable Time Slider checkbox is available only when you select Year-Quarter, Year-Month, Year-Week,
and Date. For more information about the time slider, see Using the Time Slider.
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Note
When you add only one dimension, the dimension is of date type, and the time unit is only one of the
following, in the SAP Business One Sales app, this pervasive dashboard will have three time tabs at the
bottom.
o If the time unit of the only dimension is Year, the default time tab in the pervasive dashboard in the
SAP Business One Sales app is Year.
o If the time unit of the only dimension is Year-Quarter, the default time tab in the pervasive dashboard
in the SAP Business One Sales app is Quarter.
o If the time unit of the only dimension is Year-Month, the default time tab in the pervasive dashboard in
the SAP Business One Sales app is Month.

For more information about customizing the advanced dashboard to be displayed in the SAP Business
One Sales app, see Predefined Advanced Dashboards.
For more information about the mobile app, look for the guides How to Work with SAP Business One
Sales, mobile app for iOS or How to Work with SAP Business One Sales, mobile app for Android on
sappartneredge.com.
·

For legend color, you can slice corresponding measure values from the measure axis in comparison to the
dimension that slices corresponding measure values from the dimension axis. For more information, see
Using Legend Color.

3.1.1.1

Using Legend Color
Note

You cannot use strategies if you are using the legend color function.
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Prerequisites
·

You have added only one measure, and its calculation method is not Original.

·

You have added only one dimension.

·

You are using the following chart types:
o Column chart
o Line chart
o Stacked column chart
o Multiple bar chart
o Stacked bar chart

Procedure
1.

In the Select Base Data Source window of the dashboard designer, select the query or view based on which
you want to design a pervasive dashboard.

2.

On the Basic Settings tab, drag required measures and dimensions to the target area.
The screenshot displays the sales quantities of each customer.

3.

Drag another dimension to the legend color area.
A value selection window appears, listing all the values in this dimension.
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Note
You can select a maximum of three values.
In the screenshot, item code is applied as the legend color, and Item001 and Item002 were selected as the
slicing values.

4.

Select the values that you want to use to slice the measure values, and choose the Add button.
The result area shows measure values sliced by the legend color values you selected.
The screenshot displays the sales quantities of Item001 and Item002 for each customer.

5.

[Optional] To modify the legend color values, on the Basic Settings tab, click the legend color.
The value selection window appears.
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Result
·

The legend color values appear on the Filter and Parameter tab. To edit or delete the legend color, go back to
the Basic Settings tab.
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·

In the advanced dashboard, you can view more or fewer legend color values.
In the screenshots, Item003 was also selected to display its sales quantities for each customer.

Note
Changing the legend color value only changes the display of this pervasive dashboard in the advanced
dashboard. This does not change the pervasive dashboard.
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Useful Information
·

When you drag a date type dimension to the legend color area, the time unit is automatically set to Year.

·

When you drag a date type dimension to the legend color area, if the target dimension is also of date type, the
time unit of the target dimension must be Quarter, Month, or Week.
The dashboard in the screenshot shows the monthly sales quantities in 2014 and 2015.

3.1.2

Filter and Parameter Tab

If you selected a query, the Parameters area displays the condition parameters.
If you selected a view, the Parameters area displays the input parameters of views.
On the Filter and Parameter tab of the dashboard designer, drag the required parameters and dimensions to the
target areas to design your own dashboard. During your design process, the dashboard on the right displays realtime results.
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Procedure
On the Filter and Parameter tab, you can perform the following:
·

For parameters, you can perform the following:
1.

Drag the parameters to the target area.
The Parameter Editor window appears.

2.

In the Parameter Editor window, perform the following based on the type of the parameter:
o For a date type parameter, specify a default date.

o For a number type parameter, specify a default number.

o For a string type parameter, specify a default value.

3.

To save the parameter settings, choose the Add button; to delete the parameter, in the target area,
choose the icon.

Note
Some parameters are labeled with a red rectangle. To get a meaningful pervasive dashboard, you must
drag those parameters to the target area.
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·

For filters, you can perform the following:
1.

Drag the dimensions to the filter area.
The Filter Editor window appears.

2.

In the Filter Editor window, perform the following based on the type of the dimension:
o For a string type dimension, select a filtering value, or enter a filtering value and choose the Add Value
button.
The filtering value is added to the Active Filters section.
For string type dimensions, -Current User- appears as a filtering value. If you choose this value, the
code of the logged-on user will be used as the filtering value.

Note
When the target measures filtered by certain filtering values have records in the database, then such and
only such filtering values appear in the list. If you want to use other filtering values, you need to enter
them and choose the Add Value button.
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o For a date type dimension, define a time range.

3.

To save the filter settings, choose the Add button; to delete the filter, in the target area, choose the

3.1.3

icon.

Dashboard Result Area

During your design process, this area displays real-time results. In this area, you can perform the following:
·

To enlarge or restore the dashboard result area, choose

·

To change the chart types, in the Chart Type dropdown list, select the chart type that you want to use.

or .

Note
The scatter chart supports at least two target measures.
The bubble chart supports at least three target measures.
·

To toggle between the dashboard view and the query result view, choose

or

.

Caution
In a pie chart, only the first dimension appears in the dashboard.
·

Select a strategy type to perform data analysis. For more information, see Using Strategies in the Dashboard
Designer.

·

Choose Action and add actions to the pervasive dashboard. For more information, see Adding Actions to
Pervasive Dashboards.

·

Enable the time slider for displaying time-related data. For more information, see Using the Time Slider.
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3.1.3.1

Using Strategies in the Dashboard Designer

The pervasive analytics designer allows you to use the following strategies:
·

Forecast: use this strategy to make forecasts based on your existing data.

·

K-Means Clustering: use this strategy to group all your data according to the k-means algorithm. The k-means
algorithm partitions n records into k clusters, in which each record belongs to the cluster with the nearest
center.

·

ABC Analysis: use this strategy to classify data into three categories based on the values of the target
measure in descending order.

Prerequisites
You have performed the following:
·

You have installed the Application Function Library (AFL), which includes the SAP HANA Predictive Analysis
Library (PAL). For more information about the Predictive Analysis Library, see the SAP HANA Predictive
Analysis Library (PAL) Reference guide at http://help.sap.com/hana_platform. For more information about
the database role PAL_ROLE, look for the SAP Business One Administrator's Guide, version for SAP HANA on
sappartneredge.com.

·

In the SAP HANA Studio, you have activated Script Server in your SAP HANA instance. See SAP Note
1650957 for further information.

·

For a user-defined database user, you have assigned PAL_ROLE to this database user.

·

You are not using the legend color or time slider function. For more information, see Using Legend Color and
Using the Time Slider, respectively.

3.1.3.1.1

Using the Forecast Strategy

Prerequisite
In the dashboard designer, the type of all target dimensions must be DATE.

Procedure
1.

In the Select Base Data Source window of the dashboard designer, select the query or view based on which
you want to design a pervasive dashboard.

2.

On the Basic Settings tab, specify the basic settings of the pervasive dashboard. For more information, see
Basic Settings Tab.
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3.

In the dashboard designer, in the Strategy Type dropdown list, select Forecast.
The forecast data appears in pink.

Note
The Forecast strategy supports only the column and line charts.

Note
The Forecast strategy supports only target dimensions whose display units are Year, Quarter, or Month. If
there is more than one target dimension, their display units must be in the order of Year, Quarter, and
Month.
4.

To modify settings for the strategy, choose the
area, you can define the following:

icon beside the Strategy Type dropdown list. In the settings

o Alpha, Beta, Gamma: three factors used in the forecasting calculation. For detailed information about the
calculation, see the Double Exponential Smoothing and Triple Exponential Smoothing sections in the SAP
HANA Predictive Analysis Library (PAL) Reference guide at http://help.sap.com/hana_platform.
o Forecasting Base Cycle: the cycle used for forecasting. You can change the cycle according to your own
situation. For example, if your production cycle is six months, and you have defined the smallest display
unit as Month, you define the base cycle as 6, and the forecast will be calculated on a six-month cycle
basis.
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The default cycle is determined by the smallest display unit you selected in the Target Dimensions area.
For example, the default cycle is 4 when the smallest display unit is Quarter, and the default cycle is 12
when the smallest display unit is Month.
For cycle 1, the Double Exponential Smoothing calculation is used. For cycles other than 1, the Triple
Exponential Smoothing calculation is used.

Note
The number of the smallest display units with data in the database must be greater than or equal to the
forecasting base cycle multiplied by 2.
o Forecasting Period: the number of display units to be forecast.

3.1.3.1.2

Using the K-Means Clustering Strategy

Procedure
1.

In the Select Base Data Source window of the dashboard designer, select the query or view based on which
you want to design a pervasive dashboard.

2.

On the Basic Settings tab, specify the basic settings of the pervasive dashboard. For more information, see
Basic Settings Tab.
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3.

In the dashboard designer, in the Strategy Type dropdown list, select K-Means Clustering.
The clustered data appears.

Note
The Limit to Top bar is not available for this strategy.
4.

To modify settings for the strategy, choose the
area, you can define the following:

icon beside the Strategy Type dropdown list. In the settings

o Number of Clusters (k): the number of groups into which you want your data to be clustered. The default
value is 3.
o Normalization Type: the type of the method that you want to use to normalize the data. Data
normalization means adjusting values measured on different scales to a common scale. Pervasive
analytics designer provides the following three options:
o None: no normalization type is used. This is the default value.
o Percent: for each point X (x1, x2, …, xn), the normalized value will be X' (x1/S, x2/S, …, xn/S), where S
= |x1| + |x2| + … |xn|. Each value will be converted to a new value in percentage.
o Linear: for each column C, get the min and max value of C, and then C[i] = (C[i] - min)/(max-min).
This normalization type is also known as the min-max normalization. It is a process of taking data
measured in its engineering units (for example: miles per hour or degrees C) and transforming it to a
value between 0.0 and 1.0, thus providing an easy way to compare values that are measured using
different scales (for example degrees Celsius and degrees Fahrenheit) or different units of measure
(speed and distance).
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Note
For detailed information about the calculation, see the K-Means section in the SAP HANA Predictive
Analysis Library (PAL) Reference guide at http://help.sap.com/hana_platform.

3.1.3.1.3

Using the ABC Analysis Strategy

Prerequisite
In the dashboard designer, there must be only one target measure.

Procedure
1.

In the Select Base Data Source window of the dashboard designer, select the query or view based on which
you want to design a pervasive dashboard.

2.

On the Basic Settings tab, specify the basic settings of the pervasive dashboard. For more information, see
Basic Settings Tab.
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3.

In the dashboard designer, in the Strategy Type dropdown list, select ABC Analysis.
The categorized data appears.

Note
The ABC Analysis strategy supports all chart types except the scatter and bubble charts.

Note
The Limit to Top bar is not available for this strategy.
4.

To modify settings for the strategy, choose the icon beside the Strategy Type dropdown list. In the settings
area, for the Percent parameter, you can define the specific percentage that you want each category to
occupy out of the total value in descending order.

Note
For detailed information about the calculation, see the ABC Analysis section in the SAP HANA Predictive
Analysis Library (PAL) Reference guide at http://help.sap.com/hana_platform.
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3.1.3.2

Adding Actions to Pervasive Dashboards

To access the action section of a pervasive dashboard, in the upper right corner of the dashboard designer,
choose Action. The action section displays all the actions that you have defined.

Procedure
To add actions to pervasive dashboards, follow the procedure below:
1.

In the action section of a pervasive dashboard, choose
Sidebars or Actions To Be Triggered.

(Add a New Action) beside Display Dashboard in

The edit window appears.
2.

You can add four types of actions. For more information, see the following sections.

3.

To save the action, in the edit window, choose the OK button; to delete the action, in the action section,
choose (Remove) beside the action.

3.1.3.2.1

Action: Link to SAP Business One Window

With this type of action, the current pervasive dashboard will appear in the sidebar of the linked SAP Business
One, version for SAP HANA window.

Procedure
To add action type Link to SAP Business One Window, follow the procedure below:
1.

In the action section of a pervasive dashboard, choose
Sidebars.

2.

In the edit window, select the Link to SAP Business One Window radio button.
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3.

In the Action Name field, specify the action name.

4.

In the Target SAP Business One Window dropdown list, select the window beside which you want your
pervasive dashboard to appear. You can link to only one window with one action.

5.

In the Data Binding section, select the dimension in the pervasive dashboard and link it to the field of the
selected window. To add links to more fields, choose Add a New Binding.
The pervasive dashboard will appear beside the window that you defined in the action. The value of the
defined field in the action is transferred to its linked dimension, and the pervasive dashboard will display the
data with the dimension value equal to the field value that you are exploring.
For information about how to display the dashboard as a sidebar beside the linked window, see Viewing
Linked Pervasive Dashboards in Sidebars.

6.
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To save the action, choose the OK button.
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Example
The pervasive dashboard displays the quantities of the best-selling items to the company's customers.
You link the customer dimension in the dashboard to the business partner name in the Business Partner
Master Data window. When navigating to a specific business partner in the Business Partner Master Data
window, in the sidebar, you can see the quantities of the best-selling items to this business partner.

3.1.3.2.2

Action: Open SAP Business One Window

In the Fiori-style cockpit or an advanced dashboard, this type of action will appear when you right-click the data of
pervasive dashboards. Choose this action to open the corresponding SAP Business One, version for SAP HANA
window according to the data bindings that you have defined.

Procedure
To add action type Open SAP Business One Window, follow the procedure below:
1.

In the action section of a pervasive dashboard, choose
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2.

In the edit window, select the Open SAP Business One Window radio button.

3.

In the Action Name field, specify the action name.

4.

In the Target SAP Business One Window dropdown list, select the window what you want to open. You can link
to only one window with one action.

5.

In the Data Binding section, select the dimension in the pervasive dashboard and link it to the field of the
selected window. To add links to more fields, choose Add a New Binding.
In the Fiori-style cockpit or an advanced dashboard, when you right-click a measure of the pervasive
dashboard, and choose this action, the value of the defined dimension in the action is transferred to its linked
field. The specific window appears with the field value equal to the dimension value.

6.
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To save the action, choose the OK button.
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Example
You have performed the following:
1.

In the pervasive dashboard, you added measure Total Sales Amount, and dimension Customer Code to
the pervasive dashboard.

2.

In the edit window, you selected the Open SAP Business One Window radio button, and specified Open
BP Master Data Based on Customer as its name.

3.

In the Target SAP Business One Window dropdown list, you selected Business Partner Master Data.

4.

In the Dashboard Dimension dropdown list, you selected Customer Code.
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5.

In the Target SAP Business One Window Field dropdown list, you selected BP Code.

6.

In the edit window, you chose the OK button.

Follow the procedure below to use the action:
1.
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In the Fiori-style cockpit or an advanced dashboard, right-click the total sales amount of a customer
whose code is C40000, and choose Open BP Master Data Based on Customer.
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2.

The Business Partner Master Data window appears, with the Code field value as C40000.

3.1.3.2.3

Action: Trigger Enterprise Search

In the Fiori-style cockpit or an advanced dashboard, this type of action will appear when you right-click the data of
pervasive dashboards. Choose this action to run an enterprise search with the dimension value as the search
criterion.

Procedure
To add action type Trigger Enterprise Search, follow the procedure below:
1.

In the action section of a pervasive dashboard, choose
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2.

In the edit window, select the Trigger Enterprise Search radio button.

3.

In the Action Name field, specify the action name.

4.

In the Dashboard Dimension section, select the dimension whose value you want to use as the search
criterion.

Note
If you select two or more dimensions, the application will search for results that contain all the dimension
values.
5.
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To save the action, choose the OK button.
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Example
You have performed the following:
1.

In the pervasive dashboard, you added measure Total Sales Amount, and dimension Customer Code to
the pervasive dashboard.

2.

In the edit window, you selected the Trigger Enterprise Search radio button, and specified Search for
BP Code as its name.
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3.

In the Dashboard Dimension section, you selected dimension Customer Code.

4.

In the edit window, you chose the OK button.

Follow the procedure below to use the action:
1.
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In the Fiori-style cockpit or an advanced dashboard, right-click the total sales amount of a customer
whose code is C40000, and choose Search for BP Code.
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2.

The Search Result window appears, with C40000 as its search criterion.

3.1.3.2.4

Action: Open Advanced Dashboard

In the Fiori-style cockpit or an advanced dashboard, this type of action will appear when you right-click the data of
pervasive dashboards. Choose this action to open the linked advanced dashboard with the dimension value as the
filter.

Procedure
To add action type Open Advanced Dashboard, follow the procedure below:
1.

In the action section of a pervasive dashboard, choose
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2.

In the edit window, select the Open Advanced Dashboard radio button.

3.

In the Action Name field, specify the action name.

4.

In the Target Adv. Dashboard dropdown list, select the advanced dashboard that you want to open. You can
link to only one advanced dashboard with one action.

5.

In the Data Binding section, select the dimension in the pervasive dashboard and link it to the filter of the
selected advanced dashboard. To add links to more filters, choose Add a New Binding.
For more information about filters in advanced dashboards, see Setting Up Filters and Using Filters.
In the Fiori-style cockpit or an advanced dashboard, when you right-click a measure of the pervasive
dashboard, and choose this action, the value of the defined dimension in the action is transferred to its linked
filter. The advanced dashboard appears with the dimension value as its filtering value.

6.
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To save the action, choose the OK button.
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Example
You have performed the following:
1.

In the pervasive dashboard, you added measure Total Sales Amount, and dimension Customer Code to
the pervasive dashboard.

2.

In the edit window, you selected the Open Advanced Dashboard radio button, and specified Open
Advanced Dashboard Based on Customer as its name.

3.

In the Target Adv. Dashboard dropdown list, you selected Advanced Dashboard About Customer, an
advanced dashboard that you have already created with a filter called Customer. The target dimension
of the base widget in filter Customer is BP Code. For more information about setting up filters, see
Setting Up Filters.

4.

In the Dashboard Dimension dropdown list, you selected Customer Code.
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5.

In the Target Adv. Dashboard Filter dropdown list, you selected Customer.

6.

In the edit window, you chose the OK button.

Follow the procedure below to use the action:
1.
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In the Fiori-style cockpit or an advanced dashboard, right-click the total sales amount of a customer
whose code is C40000, and choose Open Advanced Dashboard Based on Customer.
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2.

The advanced dashboard Advanced Dashboard About Customer appears, displaying data filtered by
the value C40000.

3.1.3.3

Using the Time Slider
Note

You cannot use strategies if you are using the time slider function.

Prerequisite
You have added only one dimension, the dimension is of date type, and the time unit is only one of the following:
·

Year-Quarter

·

Year-Month

·

Year-Week

·

Date

Procedure
1.

In the Select Base Data Source window of the dashboard designer, select the query or view based on which
you want to design a pervasive dashboard.
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2.

On the Basic Settings tab, drag required measures and date-type dimensions to the target area.
The dashboard in the screenshot displays sales quantities of each time period for the latest 10 months.
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3.

To enable the slider for the dashboard in the advanced dashboard, select the Enable Time Slider checkbox.
The time slider appears. You can drag the left or right bar of the slider to display the data you want.

Result
In the advanced dashboard, you can drag the time slider to view data.
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3.2

Viewing Pervasive Dashboards in the Cockpit

For more information about viewing dashboards in the cockpit, see Working with Crystal Dashboards in the online
help documentation.
You can add to your cockpit all pervasive dashboards for which you have authorizations. To set authorizations for
pervasive dashboards to users, from the SAP Business One, version for SAP HANA Main Menu, choose
Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations window,
select the user to whom you want to grant the authorization, and in Analytics → Content → Dashboard, select Full
Authorization for the pervasive dashboards to which you want to grant authorization.

3.3

Viewing Pervasive Dashboards in the Fiori-Style Cockpit

For more information about viewing pervasive dashboards in the Fiori-style cockpit, look for the How to Work with
the Fiori-Style Cockpit guide on sappartneredge.com.

3.4

Viewing Linked Pervasive Dashboards in Sidebars

Prerequisites
·

On the Display tab of the General Settings window, you have selected the checkbox Enable sidebar in windows
to display linked dashboards.

·

You have authorizations for the pervasive dashboard that you want to view. To set authorizations for
pervasive dashboards to users, from the SAP Business One, version for SAP HANA Main Menu, choose
Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations
window, select the user to whom you want to grant the authorization, and in Analytics → Content →
Dashboard, select Full Authorization for the pervasive dashboards to which you want to grant authorization.

Procedure
1.

From the SAP Business One, version for SAP HANA Main Menu, choose the required menu entry, and open
the linked window.
The window appears with a sidebar. If there is no sidebar, in the SAP Business One, version for SAP HANA
menu bar, choose View → User-Defined Fields.

2.

Choose

and select the Analytics tab to display the linked dashboard.

Note
If there is more than one dashboard linked to this window, you can choose the dashboard name or scroll
your mouse wheel to switch dashboards.
Navigating to a different record in the window generates different information based on your links.
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3.

In the displayed dashboard, to refresh the dashboard content, choose

3.5

(Refresh).

Viewing Recommendations in Sidebars

Prerequisites
·

On the Display tab of the General Settings window, you have selected the checkbox Enable sidebar in windows
to display linked dashboards.

·

You have run the recommendation service successfully, by navigating to the URL: https://<Server
Address>:<Port>/PredictiveAnalysis in a Web browser, logging on to the company you are working
with, and choosing the Refresh Now button.

Note
The URL supports the following Web browsers: Google Chrome, Microsoft Edge, Apple Safari, and Mozilla
Firefox.

Procedure
1.

From the SAP Business One, version for SAP HANA Main Menu, choose Sales - A/R → Sales Quotation or
Sales Order.
The Sales Quotation or Sales Order window appears with a sidebar. If there is no sidebar, in the SAP Business
One, version for SAP HANA menu bar, choose View → User-Defined Fields.

2.

Choose

and select the Recommendation tab to display the recommended items.
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o When you input a customer in the document, the recommended items appear in the Recommendations
for This Customer section. If this customer has no sales records or recommended items in the database,
this section will display the items that are bought most frequently company wide. You can choose the Add
button for a specific item to add it to the sales document.
o When you input an item in the document or move your mouse to an item line, the items that are most
related to this customer and this item appear in the Customers Who Bought This Item Also Bought
section. You can choose the Add button for a specific item to add it to the sales document.

Note
Every time you want to view the latest recommendation data in your company database, you must go to
the URL in the Prerequisites part to choose the Refresh Now button.

3.6

Managing Pervasive Dashboards in the Pervasive Analytics
Designer

For more information about managing crystal dashboards, for example, importing and exporting dashboard
packages, activating or deactivating a dashboard, see Working with Crystal Dashboards in the online help
documentation.
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Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To set authorizations for the pervasive analytics
designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose Administration →
System Initialization → Authorizations → General Authorizations. In the Authorizations window, select the user
for whom you want to set authorizations, and under Analytics, in Pervasive Analytics Designer, select Full
Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access the window.
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2.

In the My Dashboards section, you can find all pervasive dashboards, for which you can perform the following:
o Select each pervasive dashboard to view its contents.
o To delete a pervasive dashboard, hover your mouse over the relevant dashboard, choose the
choose the Yes button in the system message.
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3.7

Predefined Pervasive Dashboards

SAP provides the following predefined pervasive dashboards.

Note
To see a specific query, in the menu bar, choose Tools → Queries → Query Manager. For more information
about the query manager, see Query Manager in the online help documentation.
Pervasive Dashboard

Description

Data Source

Aging of Payables
Overdue (10-Day
Interval)

Vendor liabilities aging

User-defined query Aging
of Payables Overdue (10Day Interval)

Aging of Receivables
Overdue (10-Day
Interval)

Customer receivables aging

User-defined query Aging
of Receivables Overdue
(10-Day Interval)

Aging of Receivables
Overdue (30-Day
Interval)

Customer receivables aging

User-defined query Aging
or Receivables Overdue
(30-Day Interval)

Avg. Ord. Fulfillment
Days by Cust. (Last 6
Mo.)

The total of the following:

User-defined query
Monthly Average
Fulfillment Days of Sales
Orders by Customers

Average number of days it takes to deliver products
since the sales order is created for each business
partner.
This dashboard covers sales orders within this and the
last five months according to their document dates.
Fulfillment days per sales order = posting date of
delivery - posting date of sales order

Inv. Turnover of Last
12 Months (6-Month
Comp.)

Inventory turnover

User-defined query
Inventory Turnover

Inventory Turnover
(By Item Group)

Inventory turnover statistics by item group

User-defined query
Inventory Turnover (By
Item Group)

Inventory Turnover
(By Warehouse)

Inventory turnover statistics by warehouse

User-defined query
Inventory Turnover (By
Warehouse)

On-Time Dely Rate by
Number by Cust.
(Last 6 Mo.)

The total of the following:

User-defined query
Monthly On-Time Delivery
Rate by Number of
Orders by Customers

The result of the number of on-time delivered sales
orders divided by the number of all delivered sales
orders to each business partner.
This dashboard covers sales orders within this and the
last five months according to their document dates. The
deliveries whose posting dates are earlier than or equal
to the posting dates of sales orders are considered as
on-time deliveries.

How to Work with Pervasive Analytics
Working with Pervasive Dashboards

PUBLIC
© 2016 SAP SE. All rights reserved.

97

Pervasive Dashboard

Description

Data Source

Potential Amt of Open
Oppty by Stages Curr. User

Potential amount of all open opportunities of the
currently logged-on sales employee displayed by stages.

User-defined query
Opportunity

In the SAP Business One Sales app, this dashboard
appears by default when you tap the Potential Amt of
Open Opportunities - Curr. User KPI in the KPI screen.
For more information about opening pervasive
dashboards from KPIs in the SAP Business One Sales
app, see Action: Open Dashboard (For the SAP Business
One Sales App).

Revenue Versus
Gross Profit for Last 6
Months

Comparison of revenue and gross profit

User-defined query
Revenue Versus Gross
Profit for Last 6 Months

Revenue Versus
Gross Profit for Last 6
Years

Comparison of net sales amount and gross profit in this
and the last five years

Calculation view
Profitability Analysis

Sales Order Amount
by Mo./Qty/Yr (LC) Curr. User

The total sales order amount of the currently logged-on
sales employee displayed by months.

User-defined query Sales
Order

In the SAP Business One Sales app, this dashboard
appears by default when you tap the Sales Order
Amount of This Month (LC) - Curr. User KPI in the KPI
screen, and can be displayed by months, quarters, or
years.
For more information about opening pervasive
dashboards from KPIs in the SAP Business One Sales
app, see Action: Open Dashboard (For the SAP Business
One Sales App).

Sales Order Amount
by Months (LC)

The total sales order amount displayed by months.
In the SAP Business One Sales app, this dashboard
appears on the General tab of customers by default, and
displays the total sales order amount of the specific
customer by months, quarters, or years.

User-defined query Sales
Order

For more information about customizing the advanced
dashboard to be displayed in the SAP Business One
Sales app, see Predefined Advanced Dashboards.
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Top 5 Best Selling
Items by Sales
Amount

Items ranked by sales amount based on invoices

User-defined query Best
Sellers by Sales Amount

Top 5 Best Selling
Items by Sales
Amount (Mobile)

Items ranked by sales amount based on invoices.

User-defined query Sales
Invoice

In the SAP Business One Sales app, this dashboard
appears on the General tab of customers by default, and
displays the items ranked by sales amount based on the
invoices of the specific customer.
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Pervasive Dashboard

Description

Data Source

For more information about customizing the advanced
dashboard to be displayed in the SAP Business One
Sales app, see Predefined Advanced Dashboards.
Top 5 Best Selling
Items by Sales Amt Curr. User

Items ranked by sales amount based on the invoices of
the currently logged-on sales employee.

User-defined query Sales
Invoice

In the SAP Business One Sales app, this dashboard
appears in the KPI screen by default.
For more information about customizing the advanced
dashboard to be displayed in the SAP Business One
Sales app, see Predefined Advanced Dashboards.

Top 5 Best Selling
Items by Sales Amt of
This Year

Items ranked by sales amount based on invoices in this
year

Calculation view
Profitability Analysis

Top 5 Customers by
Receivables Overdue

Customers ranked by receivables overdue

User-defined query
Customers by
Receivables Overdue

Top 5 Customers by
Sales Amount

Customers ranked by sales amount based on invoices

User-defined query
Customers by Sales
Amount

Top 5 Customers by
Sales Amount - Curr.
User

Customers ranked by sales amount based on the
invoices of the currently logged-on sales employee.

User-defined query Sales
Invoice

In the SAP Business One Sales app, this dashboard
appears in the KPI screen by default.
For more information about customizing the advanced
dashboard to be displayed in the SAP Business One
Sales app, see Predefined Advanced Dashboards.

Top 5 Item Groups by
Inventory Value

Item groups ranked by item inventory value in the
groups

User-defined query Item
Groups by Inventory
Value

Top 5 Purchased
Items by Purchase
Amount

Items ranked by purchase amount based on invoices

User-defined query
Purchased Items By
Purchase Amount

Top 5 Sales
Employees by Sales
Amount

Sales employees ranked by sales amount based on
invoices

Calculation view
Profitability Analysis

Top 5 Vendors by
Payables Overdue

Vendors ranked by payables overdue

User-defined query
Vendors by Payables
Overdue

Top 5 Vendors by
Purchase Amount

Vendors ranked by purchase amount based on invoices

User-defined query
Vendors by Purchase
Amount
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Pervasive Dashboard

Description

Data Source

Total Purchase
Versus Goods Return
for Last 6 Months

Comparison of purchase amount and goods return

User-defined query Total
Purchase Versus Goods
Return for Last 6 Months
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4

Working with Advanced Dashboards

An advanced dashboard can contain the following widgets:
·

Pervasive dashboard

·

Key performance indicator (KPI)

·

Count

·

Business Partner Info

The major functions include, but are not limited to, the following:
·

You can view an advanced dashboard in pages.

·

You can add filters to specific widgets to see only the data related to what interests you.

·

You can use actions of the widgets in the advanced dashboard.

4.1

Designing Advanced Dashboards Using the Pervasive
Analytics Designer

Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To grant authorizations for the pervasive
analytics designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose
Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations
window, select the user for whom you want to set authorizations, and under Analytics, in Pervasive Analytics
Designer, select Full Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access this window.

How to Work with Pervasive Analytics
Working with Advanced Dashboards

PUBLIC
© 2016 SAP SE. All rights reserved.

101

2.

On the left side of the Pervasive Analytics window, choose New Advanced Dashboard.
A blank advanced dashboard appears in edit mode.

3.

To add a widget, in the upper right corner of the advanced dashboard, choose

(Add Widgets).

The widget gallery appears.
4.

In the widget gallery, select the widget that you want to add to the current page of your advanced dashboard.
To find a widget in a specific category, in the upper left corner of the widget gallery, select the category that
you want to explore.
To find a specific widget, in the upper right corner of the widget gallery, enter the widget name, or part of the
name, to search for the widget.
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5.

After you select the widgets, in the upper left corner of the widget gallery, choose

(Go Back).

The widgets appear in the current page of the advanced dashboard in edit mode.

6.

To specify new names for the current page and advanced dashboard, click the titles of the page and advanced
dashboard, and enter the names.

7.

[Optional] To add a filter for the advanced dashboard, in the upper right corner of the current page, choose
(Filter Settings). For more information, see Setting Up Filters.

8.

To save the advanced dashboard, in the upper right corner of the advanced dashboard, choose
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4.1.1

Edit Mode

In the pervasive analytics designer, when you design a new advanced dashboard or open an existing advanced
dashboard, the dashboard appears in edit mode.

In the edit mode of an advanced dashboard, you can perform the following:
·

To specify a new name for the current page or advanced dashboard, click the title of the page or advanced
dashboard, and enter the name.

·

To add a new page, to the right of the current page name, choose

·

To delete an existing page, beside the name of the page that you want to delete, choose

·

To add a widget, in the upper right corner of the advanced dashboard, choose

·

To change the place of a widget, select the widget that you want to move, and drag it to the place that you
prefer.
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·

To delete a widget, select the widget that you want to delete, and drag it to the red area in the lower right
corner.

·

To add a filter, in the upper right corner of the current page, choose
information, see Setting Up Filters.

·

To save the advanced dashboard, in the upper right corner of the advanced dashboard, choose

·

For a pervasive dashboard, to change its size, around the pervasive dashboard, choose the minus or plus sign.
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4.1.2

View Mode

The view mode appears in the following situations:
·

In the edit mode of the advanced dashboard, in the upper right corner of the advanced dashboard, you
choose
(Save).

·

In the view mode of the advanced dashboard, or in the Fiori-style cockpit, you open an advanced dashboard
from the action of a pervasive dashboard or KPI.

In the view mode of an advanced dashboard, you can perform the following:
·

To refresh the data, in the upper right corner of the advanced dashboard, choose

·

To edit the advanced dashboard, in the upper right corner, choose

·

To use the filters, in the upper right corner of the current page, choose
Using Filters.

·

To go back from the current advanced dashboard to the previous one, in the upper left corner of the advanced
dashboard, choose the name of the previous dashboard.

·

To perform actions defined for a pervasive dashboard, right-click the data for a dimension, and choose the
action.

·

To perform an action defined for a KPI, click anywhere on the KPI.

·

To perform an action for a count widget, choose the number of the widget.
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·

For a pervasive dashboard, you can perform the following:
o To toggle between the dashboard view and the query result view, in the upper right corner of the
pervasive dashboard, choose
(Switch to Chart) or
(Switch to Table).

o To refresh the pervasive dashboard, in the upper right corner of the pervasive dashboard, choose
(Refresh).

o For pervasive dashboards for which you have defined legend color, to view data based on different legend
color values, in the upper right corner of the pervasive dashboard, choose . The pervasive dashboard in
the screenshots displays data with the two legend color values selected when the dashboard was
designed. When you select another legend color value, the pervasive dashboard displays data based on
the three legend color values. For more information about legend color, see Using Legend Color.
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Note
Changing the legend color value only changes the display of this pervasive dashboard in the advanced
dashboard. This does not change the pervasive dashboard.
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o For pervasive dashboards for which you have enabled the time slider, to change the data view in different
time period, drag the left or right bar of the slider.

o To enlarge the pervasive dashboard in the dashboard designer, in the upper right corner of the pervasive
dashboard, choose (Enlarge the Dashboard). In its enlarged view, you can change the settings of the
pervasive dashboard for a new result, but you cannot save the changed pervasive dashboard.

o To go back to the advanced dashboard, in the upper left corner of the dashboard designer, choose
(Go Back).

4.1.3

Setting Up Filters

You can set up filters for specific widgets in the whole advanced dashboard.
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Procedure
In the edit mode of an advanced dashboard, to set up filters, follow the procedure below:
1.

In the upper right corner of the current page, choose

(Filter Settings).

The Filter Settings page appears.

2.

In the left pane, choose Add Filter.
Filter settings appear in the right pane.
The Target Widgets section lists all the widgets except the count widget in the advanced dashboard, and you
can view them by pages.

3.

In the Filter Type section, select String or Date as your filter type.

4.

In the Filter Type section, if you select the Single Value Selection checkbox, when you use this filter, you can
select only one filtering value. If you deselect the Single Value Selection checkbox, when you use this filter,
you can select multiple filtering values.

Note
For a filter that includes a Business Partner Info widget, you must select the Single Value Selection
checkbox.
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5.

To include specific widgets in your filtering scope, in the Target Dimension column of those widgets, select the
dimension that you want to set as the filter.
For widgets whose base data source is a query, the Target Dimension dropdown list contains all the nonnumerical columns of the query.
For widgets whose base data source is a view, the Target Dimension dropdown list contains all the attributes
of the view.

Note
Filter settings does not support composite KPIs. The Target Dimension and Base columns for composite
KPIs are disabled.
6.

To set a base widget, proceed as follows:
1.

In the Target Widgets section, locate the widget from which you want to retrieve the filtering values.

2.

In the Target Dimension column of the target widget, select the dimension whose values you want to
retrieve as the filtering values, and select its Base column.

Note
If you define two or more target widgets, those widgets will be refreshed to display the filtered data when
you use the filter, and the filtering values will be retrieved from the target dimension of the base widget.

Note
All widgets except KPI can be used as base widgets.
7.

To save the filter, in the upper right corner of the filter settings, choose

4.1.4

(Save).

Using Filters

You can use filters for target widgets that you have defined in the filters.
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Procedure
In the view mode of an advanced dashboard, to use filters, follow the procedure below:
1.

In the upper right corner of the current page, choose

(Filters).

The Filter By window appears.

2.

Select the filter that you want to use.
The filtering values are retrieved from the target dimension of the base widget.

3.
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To clear the values that you just selected, in the upper right corner, choose

(Clear All Filters).

Note
You can set the selection method for the filtering values, single selection or multiple selections, by setting
the Single Value Selection checkbox in the filter.
4.

In the upper left corner, choose

.

The number of filtering values appears beside the filter you just used.

Note
To use two or more filters, select them, and select the filtering values.
To clear all filters, in the upper right corner, choose
5.

(Clear All Filters).

In the Filter By window, choose the OK button.
The data of the target widgets are filtered by the values you selected.

4.2

Viewing and Managing Advanced Dashboards in the
Pervasive Analytics Designer

Prerequisites
·

You have installed the app framework for SAP Business One, version for SAP HANA. For more information
about installing the app framework, look for the Working with App Framework for SAP Business One, version
for SAP HANA guide on sappartneredge.com.

·

You have authorizations for the pervasive analytics designer. To grant authorizations for the pervasive
analytics designer to users, from the SAP Business One, version for SAP HANA Main Menu, choose
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Administration → System Initialization → Authorizations → General Authorizations. In the Authorizations
window, select the user for whom you want to set authorizations, and under Analytics, in Pervasive Analytics
Designer, select Full Authorization.

Procedure
1.

In the SAP Business One, version for SAP HANA toolbar, choose

(Pervasive Analytics).

Alternatively, in the SAP Business One, version for SAP HANA menu bar, choose Tools → Pervasive Analytics.
The Pervasive Analytics window appears.

Note
Only users with authorizations for the pervasive analytics designer can access the window.
2.

In the My Advanced Dashboards section, you can find all the advanced dashboards, for which you can
perform the following:
o Select each advanced dashboard to view its contents.
o To delete an advanced dashboard, hover your mouse over the relevant dashboard, choose the
and choose the Yes button in the system message.
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4.3

Predefined Advanced Dashboards

SAP provides the following predefined advanced pervasive dashboards.
For more information about the KPIs and pervasive dashboards contained in the predefined advanced
dashboards, see Predefined KPIs and Predefined Pervasive Dashboards.

Adv. Dashboard for SAP Business One Sales App - Curr. Sales EE
In the SAP Business One Sales app, this advanced dashboard appears in the KPI screen by default. For more
information about the mobile app, look for the guides How to Work with SAP Business One Sales, mobile app for
iOS or How to Work with SAP Business One Sales, mobile app for Android on sappartneredge.com.
This advanced dashboard contains the following KPIs and pervasive dashboards. For more information about the
KPIs and pervasive dashboards, see Predefined KPIs and Predefined Advanced Dashboards.
·

Potential Amt of Open Opportunities - Curr. User (KPI): when you tap this KPI in the SAP Business One Sales
app, the Potential Amt of Open Oppty by Stages - Curr. User pervasive dashboard appears.

·

Sales Order Amount of This Month (LC) - Curr. User (KPI): when you tap this KPI in the SAP Business One
Sales app, the Sales Order Amount by Mo./Qty/Yr (LC) - Curr. User pervasive dashboard appears.

·

Top 5 Customers by Sales Amount - Curr. User (pervasive dashboard)

·

Top 5 Best Selling Items by Sales Amt - Curr. User (pervasive dashboard)

You cannot delete the predefined advanced dashboard, but you can modify it. It is the first page of this advanced
dashboard that appears in the KPI screen in the SAP Business One Sales app.

Adv. Dashboard for SAP Business One Sales App - Customer
In the SAP Business One Sales app, this dashboard appears on the General tab of customers by default. For more
information about the mobile app, look for the guides How to Work with SAP Business One Sales, mobile app for
iOS or How to Work with SAP Business One Sales, mobile app for Android on sappartneredge.com.
This advanced dashboard contains the following KPIs and pervasive dashboards. For more information about the
KPIs and pervasive dashboards, see Predefined KPIs and Predefined Advanced Dashboards.
·

Sales Order Amount by Months (LC) (pervasive dashboard)

·

Total Amount of Open Deliveries (LC) (KPI)

·

Customer Balance (LC) (KPI)

·

Top 5 Best Selling Items by Sales Amount (Mobile) (pervasive dashboard)

You cannot delete the predefined advanced dashboard, but you can modify it. It is the first page of this advanced
dashboard that appears in the KPI screen in the SAP Business One Sales app.
When displayed on the General tab of customers in the SAP Business One Sales app, the data is based on the
specific customer you are exploring.
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Note
To make sure the first page of this advanced dashboard displays data based on the specific customer in
the SAP Business One Sales app, in the data source of the KPIs and dashboards contained in the first
page, there must be a dimension called CardCode, and the name is case sensitive. Otherwise, the data
will not be based on the specific customer you are exploring.
The following is an example of a KPI data source that contains a dimension called CardCode:
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The following is an example of a pervasive dashboard data source that contains a dimension called
CardCode:

Customer 360
For more information about working with Customer 360, see Working with Customer 360.
This advanced dashboard contains the following KPIs and pervasive dashboards. For more information about the
KPIs and pervasive dashboards, see Predefined KPIs and Predefined Advanced Dashboards.
·

General tab:
o Business Partner Profile
o Total Sales Amount (LTD) (KPI)
o Gross Profit (LTD) (KPI)
o Number of Open Service Calls (KPI)
o Revenue Versus Gross Profit for Last 6 Years (pervasive dashboard)
o Potential Amt of Open Opportunities (KPI)
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o Churn Probability (KPI)
o Opportunity Win Rate (LTD) (KPI)
o Weighted Amount of All Open Opportunities (LC) (KPI)
·

Sales tab:
o Business Partner Profile
o Total Sales Amount (YTD) (KPI)
o Gross Profit (YTD) (KPI)
o Gross Profit Margin (YTD) (KPI)
o Revenue Versus Gross Profit for Last 6 Months (pervasive dashboard)
o Top 5 Best Selling Items by Sales Amt of This Year (pervasive dashboard)
o Number of Open Sales Quotations (KPI)
o Number of Open Sales Orders (KPI)

·

Logistics tab:
o Business Partner Profile
o On-Time Delivery Rate (KPI)
o Average Fulfillment Days for a Sales Order (KPI)
o Sales Return Amount for This Year (KPI)
o Avg. Ord. Fulfillment Days by Cust. (Last 6 Mo.) (pervasive dashboard)
o On-Time Dely Rate by Number by Cust. (Last 6 Mo.) (pervasive dashboard)
o Number of Open Deliveries (KPI)
o Open Amount of Deliveries (KPI)

·

Receivables tab:
o Business Partner Profile
o Credit Limit Deviation (KPI)
o Total Receivable Amount YTD (KPI)
o Receivables Overdue (KPI)
o Aging of Receivables Overdue (30-Day Interval) (pervasive dashboard)

You cannot delete the predefined advanced dashboard, but you can modify it.
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5

Working with Customer 360

Procedure
1.

In the SAP Business One, version for SAP HANA Main Menu, choose Business Partners → Business Partner
Master Data.

2.

In the Business Partner Master Data window, navigate to a customer, and in the lower-right corner, choose
You Can Also → View Customer 360.
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The Customer 360 advanced dashboard appears, displaying a 360-degree view of the customer. For more
information about the advanced dashboard, see Predefined Advanced Dashboards.
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